[ltp] HTTP installation

Vasanth Rakasi linux-thinkpad@www.bm-soft.com
Sun, 26 Dec 1999 20:05:21 -0800 (PST)

Having failed with trying to install through NFS, I am
trying installing RedHat 6.1 using HTTP.

Please take a look at the 3 pieces of information

1) The window on the laptop (on which I am trying to
install RH6.1) says:

Loading second stage ramdisk...

The above message has been there throughout the night.

2) 'ls -l' on RedHat/base/stage2.img shows:
-rw-r--r--      1 root  root    2885842 Sep 27 09:04

3) The file /etc/httpd/logs/access_log shows: - - [25/Dec/1999:23:45:21 -0800] "GET
//cdrom/RedHat/base/stage2.img HTTP/1.0" 200 529697
(The above log says that a request from a client was
successful and 529697 bytes of data was transferred to
the client.)

Howcome only 529697 bytes got sent when the file
itself is over 2MB?

I have increased the Timeout in httpd.conf from 300 to
1000 (seconds) but this hasn't helped.

The two options that I am passing to kernel are:

Any ideas?


--- Vasanth Rakasi <v_rakasi@yahoo.com> wrote:
> I am trying to install RedHat Linux 6.1 on old,
> Pentium-based IBM thinkpads--models 365E and 755CX.
> Niether of these has a a CD-ROM drive. Both of them,
> however, have floppy disk drives. The hard disk
> space
> on both the ThinkPads is 540MB and and is wiped
> clean
> with Partition Magic. Each of them has 8MB RAM.
> I am trying the installation through nfs, running on
> another desktop PC (which has a CD-ROM drive and)
> running RedHat Linux 6.1. I am able to connect the
> ThinkPads to the network using an NE2000 compatible
> PCMCIA card. 
> I'm  using RedHat 6.1's pcmcia.img and
> gdth-driver-disk.img which I got from RedHat's site
> and used rawrite.exe to copy on to floppy diskettes.
> With the help of these two ".img" files, I'm able to
> get to the point where I need to select an
> installation method--NFS.
> (at this point, when I ping this machine from
> another
> machine, I do get a response--showing that the
> network
> card is working OK. I can hear the spinning of
> on the desktop PC in response to the installation on
> the thinkpads.)
> Installation, however, fails with the following
> error
> (let's call it error_1):
> -------------------
> install exited abnormally -- received signal 7
> sending termination signals...done
> sending kill signals...done
> unmounting filesystems...
>                 /mnt/source
>                 /dev/pts
>                 /proc
> you may safely reboot your system
> -------------------
> When I try to get to "bash#" during the installation
> procedure (by temporarily not answering the
> questions
> asked by the installaion program), I tried "fdisk
> /dev/hda", "fdisk /dev/sda" and "fdisk /dev/eda"
> only
> to see "Unable to open /dev/hda",
> "Unable to open /dev/sda", etc. 
> I When I do "ls /dev", the following is what I see:
> -------------------
> console mem             ptmx    tty0    tty3    tty6
>  ttyS1   zero
> log     null    pts     tty1    tty4    tty7   
> ttyS2
> md0     psaux   ram     tty2    tty5    ttyS0  
> ttyS3
> -------------------
> I don't see hda, sda or eda. 
> Somebody on the linux thinkpad newsgroup suggested I
> use "mknod" to get "/dev/hda", "fdisk"
> to create linux and swap partitions /dev/hda1 and
> /dev/hda2 respectively. Even after I do this, I
> still
> get the same error (error_1 above).
> Any help from you would be deeply appreciated.
> vasanth

Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com
----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: