16 bpp X on vanilla 770?

Matthias Wandel linux-thinkpad@www.bm-soft.com
Sun, 6 Jun 1999 19:13:38 -0400

I'm no expert... but..

There is a website on running X on a thinkpad 770x, with a modified XF86 and
xconfig file to go with it - should handle 1024x768 as well.  Just search
for "thinkpad 770x" and linux on altavista.

My brother got the sound on my laptop working mysteriously - by unloading
and reloading the sound driver.  Neither of us knows why this works, but the
startup sccript now unload and reloads the driver, and it works beautifully.


-----Original Message-----
From: ratkins@osix.com.au [mailto:ratkins@osix.com.au]
Sent: June 6, 1999 7:08 PM
To: linux-thinkpad@bm-soft.com
Subject: 16 bpp X on vanilla 770?

Hi all,

I've got a plain tp770 (9549-1AA) with a DVD-ROM drive. I've just
installed RedHat 6.0, and I get X (with Gnome and E) automagically.
SuperProbe reports that I've got a Trident Cyber9397 chipset with 2Mb of

How do I get X in 16 bit? E and GNOME look really ugly in 256 colours,
and I can get Windows to work in 16 bit at 1024x768. I tried changing
the "exec X" line in one of those files in /etc/X11 (can't remember which
one) to add the -bpp 16 option but it didn't have any effect. 

Any clues? I'm using the plain XF86_SVGA server I think, at version, is this the right one to use for my machine?

Oh, and I've had no luck with sound either. If I run sndconfig it doesn't
find any sound chips. When I select the plain SoundBlaster I get the
sample, though it's a bit chopped up, and no MIDI. But when I select the
Crystal Audio chip (which Winblows says my machine has) I get a couple of
crackles instead of a sample but the MIDI works. 

 * @author Robert Atkins, ratkins@osix.com.au
 * "Robert must learn to sit still." - My kindergarten report