Fri, 25 Jun 1999 09:56:09 -0400

Actually, Redhat does indeed have a RPM for the latest pcmcia driver.  Look
There also kernel updates in that directory if you want them.  I have a 770
running RedHat 6.0  (linux kernel 2.2.5-22) with these drivers installed and my
Token Ring works fine. on 06/25/99 09:01:52 AM

Please respond to

cc:    (bcc: Jerry Craker/Falls Church/IBM)
Subject:  Re:


my IBM PCMCIA Turbo 16/4 Token Ring Card is working fine.
But it was a really hard job...  ;-))

I am running SuSE Linux 6.1 on the 770X, but I guess problems are the same.
Obviously kernel 2.2.7 is recommended (available as *.rpm). I can't say if
your RedHat 2.2.5 is working. Besides that I had to use pcmcia package
3.0.12. There's a new driver included so you have to use this package.
Otherwise your card won't work. May be there's already an update available
from RedHat. If not, try this one...

May be first make the pcmcia package. For help look at the pcmcia-howto. I
had to uninstall the SuSE pcmcia support before.

Bests regards, Holger Daasch
SerCon GmbH
Calwer Strasse 7, D-71034 Boeblingen
Phone: +49 7031 16 2448, email:, Lotus Notes Mail:
Holger Daasch/Germany/IBM@IBMDE on 25.06.99 13:14:19

Please respond to

cc:    (bcc: Holger Daasch/Germany/IBM)

I've got a 770X and have visited Bill's page so thanks for enabling me to
get my Xserver working.

I've visited the web pages I could find related to the 770X and setting up
a PCMCIA Token Ring Card but I still haven't been able to get the Token
ring working. I haven't tried recompiling the kernel but I don't really
want to yet, I'd rather get a working system if possible before I cause
more problems :-)

Anyway I am running RedHat 6 with kernel 2.2.5-15 and pcmcia 2.2.5-15
My card is an IBM PCMCIA Turbo 16/4 Token Ring Card

The error I keep getting happens when booting.

Delaying tr0 initialisation.             FAILED
Sarting NFS statd                  OK
Starting NFS quotas: tr0: Initial interrupt: 16 Mbps, shared RAM base
tr0:open failed: ret_code = 34, retrying
tr0:open failed: ret_code = 34, retrying
tr0:open failed: ret_code = 34, retrying
tr0:open failed: ret_code = 34, retrying
tr0:open failed: ret_code = 34, retrying


I'm not that familiar with hacking around and setting up Linux, I seemed to
have had an easy time of setting it up until now! Mind you this is the
first laptop I've tried to set up.

Any suggestions appreciated,