[ltp] new pcmcia lossage with rh 6.1

Jamie Zawinski linux-thinkpad@www.bm-soft.com
Wed, 03 Nov 1999 04:42:14 -0800

I've got a Xircom pcmcia ethernet/modem card with a 770ED, and when 
I was running RH 5.2 (2.0.36) suspend/resume worked fine.  I just 
upgraded to 6.1 (2.2.12) and now after I resume, I need to do
"/etc/rc.d/init.d/pcmcia restart" before the machine becomes 
pingable again.  I didn't have to do this with 5.2.

To get suspension to work at all, I had to rebuild the kernel;
I ran "make xconfig" and selected:

            ignore user suspend - yes (was no)
            enable pm at boot - yes (was no)
            make cpu idle calls - yes (was no)
            enable console blanking - yes (was no)
            ignore multiple suspend - yes (was no)
            ignore multiple suspend/resume cycles - no (was no)
            allow interrupts during bios calls - yes (was no)

Is there something else I'm missing, or is this some new bug that
the 2.2 kernels have that the 5.2 kernels didn't?

(BTW, I've also disabled apmd, in case that matters -- I never got
apmd to work right with 5.2.)

Any suggestions?

Jamie Zawinski             jwz@jwz.org             http://www.jwz.org/
----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: