[ltp] Experience from updating RH 6.2 to RH 7.0 on TP 770X

Burt Silverman linux-thinkpad@www.bm-soft.com
Sat, 25 Nov 2000 19:25:54 -0500

Friedemann Baitinger fb@baiti.net       http://baiti.net/fb/writes:
>In 1 out of 2 days when I
>come into the office (obviously the Thinkpad still running, just
>disconnected from my Ethernet at home) and I plug the Token Ring card I
>get the transmitter busy. The bad thing is that the /etc/init.d/pcmcia
>restart does _not_ help. Today I was not even able to power down the
>system anymore. Neither did /etc/init.c/pcmcia stop work, nor pulling
>the card. Even after pulling the card I got the transmitter busy and I
>finally had to use the electrical power off.


I need you to stick with the program a bit longer before declaring it a
lost cause.

1. The one situation where I do not have total confidence in hot plug is
during standby. I just haven't tried it enough times to be sure. I just
gave it a try, and it recognizes a card removal during standby, but not an
insertion. Now I am doing a PCMCIA restart, and it is not detecting the
card that I had inserted during standby. I had to reinsert the card. But
everything else is AOK. I am not an authority in this area; in fact, one of
your notes is my main reference for standby.

2. I want you to use the new driver, and send me the /var/log/messages for
the problem area.

I want you to put in the fix that I mentioned in ibmtr.c around line 1057
to use ti->mmio rather than ti->sram_virt for the assignment to
check_reason. The one instance of your message log I viewed showed that an
adapter check had occurred. An adapter check is supposed to be indicative
of bad hardware, somewhere along the ring. This is when ideally you have an
extra adapter, a colleague's laptop, perhaps even another ring or port to
attach to, so you can try and isolate that problem. Adapter checks should
not be happening under normal circumstances, but I have had them and I work
with some flaky hardware -- I believe my 760EL ThinkPad has a quirk. (I
have just upgraded it from pcmcia_cs-3.1.8 to pcmcia_cs-3.1.22 and the jury
is still out on whether the problems disappear long term).

3. I located another bug that has been sitting around for a long time. This
one is responsible for the situation in which you have no alternative than
to reboot. A network device structure is created early in the game, and
with the current bug, if you fail to make it through initialization, the
device structure doesn't get removed from the device list. You know this
has happened if you remove the card and then do "ifconfig tr0" and tr0

I want you to go to around line 333 in ibmtr_cs.c and locate the line "if
(link->dev) [under the /*Unlink device structure, free bits*/ comment.] I
want you to change the word "link" to the word "info" and rebuild and
reinstall ibmtr_cs.o. Indeed, while I was developing the enhancements I
wasted 5 minutes many times because I had not tracked down that bug.

>Needless to say that I had
>to undergo the timeconsuming filesystem check afterwards. In essence I
>lost 30 minutes.

If 100% reliable hardware is not obtainable in your Token Ring/PCMCIA
section I think there may be a filesystem fix. One thing is, DO NOT PUT
FASTBOOT INTO /. I have one large partition, everything under /. But if you
make / and /var relatively small, MAYBE the filesystem check will be
limited to those small filesystems. I tried with /var, and that was not
going far enough; I didn't proceed to /. This is probably why AIX always
has used small /. The drawback is that you then need separate filesystems
for /usr, /home, /opt, /tmp (copying AIX, /etc and /bin are part of /). It
will be easier when the journaled filesystems come into Linux, so you can
enlarge them when necessary. Partition Magic from PowerQuest is very
powerful, but jfs allows you to enlarge (but not shrink) the filesystems

And remember what I told my brother:
I found a way to fix my Thinkpad when the PCMCIA goes on the fritz. I slap
it on the right side towards the front. But it is fascinating, because,
when I give it that slap, the Thinkpad emits a high frequency tone for
about one second. Invariably, the next time I start it (PCMCIA) up,
everything is OK. The tone is an electronically generated tone, not a
mechanical one. That is my impression, and the tone usually doesn't repeat
if I continue to slap the Thinkpad. If I slap the Thinkpad a little too
hard, the disk must get out of whack (I dont really know, but the disk is
close to the slapping area); the Thinkpad looses its marbles and won't talk
to me until I reboot it.

Hope you will give it another shot.

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: