[ltp] tp600 / rh7.1 install/run issues

Richard Neill linux-thinkpad@www.bm-soft.com
Wed, 04 Jul 2001 00:05:38 +0100

Being a Linux Newbie, (ie doing some research *before* taking the plunge with
a thinkpad), I found this from a friend about Thinkpad Trackpoint support. I'm
not certain it's accurate, but it might be useful?


" It's a known issue in the version of the kernel that was released with
8.0.  If you use a more recent version (e.g. the recently-released
MandrakeFreq) then you will get a version of the kernel in which the
problem is fixed.  Alternatively, you might be able to work around it by
using a serial mouse during installation, then installing an upgraded
kernel before using the internal PS/2 mouse."


Ricardo Cardenas wrote:
> Yes, Mandrake 8.0 definitely has a problem with the PS/2 mouse. They broke
> support for it in the 2.4 kernel. There is a procedure to install with a
> boot floppy, which uses an earlier image and allows you to install Mandrake
> 8.0 and have PS/2 mouse support. I tried it and it worked. I can't seem to
> find it on the net, but if you really need this, email me and I'll find it.
> But instead of downgrading the kernel, you might consider moving to another
> distro that supports the mouse correctly. I installed RedHat 7.1 from
> scratch on a TP 600E. It was completely smooth, and I have APM, PS/2 mouse,
> and PCMCIA network card support, without having to recompile or move any
> switches.
> Regards
> Ricardo
> Mexico City
> -----Original Message-----
> From: Bradley W. Langhorst [mailto:brad@langhorst.com]
> Sent: Tuesday, July 03, 2001 17:47
> To: linux-thinkpad@www.bm-soft.com
> Subject: Re: [ltp] tp600 / rh7.1 install/run issues
> >
> > -------
> >
> > That's the scoop. I attempted an install of Mandrake 8.0 today and it
> seemed
> > as though it was progressing well until I had to utilize the built-in
> > pointer and found it was non-operational and therefore had to discontinue
> > the install. Apparently the lack of support for the Thinkpad mouse/pointer
> > in Mandrake 8.0 is a known issue.
> >
> > Any ideas on this one? I'm at a loss and IBM doesn't sound as if they're
> > interested in supporting this faithful (albeit fading) customer...
> >
> > Thanks,
> > Mike Wagner
> >
> I can't explain the lockup issues. It may be hardware - given the failed
> tests.
> However, your win2k results seem to eliminate that possibility.
> But I think I read that mandrake does not detect the trackpoint
> properly.  I've never used it but maybe somebody else here can comment
> on that.  You also might try installing an older disitribution like
> debian potato or redhat 6.
> good luck
> brad

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: