[ltp] Full-duplex sound on A20p / A20m

Marco Rovere linux-thinkpad@www.bm-soft.com
Wed, 13 Feb 2002 11:47:35 +0100 (CET)

On 12 Feb 2002, Mike Johnson wrote:

> On Tue, 2002-02-12 at 15:46, Darwin Marcus Johnson wrote:
> > Mike Johnson wrote:
> >
> > >On Tue, 2002-02-12 at 11:40, Marco Rovere wrote:
> > >
> > >>Hi Mike, I'm experiencing exactly the same problem on my A20m.
> > >>
> > Are you running ALSA or the Kernel(OSS/Free) Drivers?
> >  OSS/Free drivers are known to have issues with full duplex audio.
> I have tried both. The ALSA drivers improve the received
> sound by about 5%.
> Mike.

Hi Mike, just this night I managed to make things work.
I connect my 2 PC (laptop A20m and Desktop) both running linux and I used
gphone and everything worked great after a few aumix fine tuning of Mic
and Speaker.

Dunno what's wrong with ohphone which still doesn't work.
I attach again the modules loaded at boot time for my soundcard:

Module                  Size  Used by
cs46xx                 56192   2
soundcore               3984   3  [cs46xx]
ac97_codec              9008   0  [cs46xx]

This is /etc/modules.conf

alias sound-slot-0 cs46xx

That's it.

When and if I'll be able to use ohphone I'll let you know.

Just a stupid check: try to use gphone and call yourself and see what


----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: