[ltp] Major crash with a TP600 on RH 7.2

Robert Hollis linux-thinkpad@www.bm-soft.com
Tue, 19 Feb 2002 11:15:06 -0600

If system was working and nothing changed I would suspect hardware
(probably HD) as the culprit.  Unfortunately the only way to check at this
point is either to reload or run diags on system.  There is a diags disk
available from pc company web site but I have not tried it.

Robert Hollis
630-573-7383 (T/L 677)
e-mail - vdrlholl@us.ibm.com

2707 Butterfield Rd.
Oak Brook, IL.  60523

                    Bernard DEBREIL                                                                                       
                    <bdebreil@free.fr>           To:     linux-thinkpad@www.bm-soft.com                                   
                    Sent by:                     cc:                                                                      
                    owner-linux-thinkpad@b       Subject:     [ltp] Major crash with a TP600 on RH 7.2                    
                    02/17/02 10:13 AM                                                                                     
                    Please respond to                                                                                     

Hi there,

I have been using, on an everyday basis, a TP600 (300 Mhz, 128 MB RAM,
3 MB of HD),  on RH 7.2 ever since mid december 2001. In spite of a
few things that I didn't like, it worked allright and fulfilled most
of my needs, and, as far as internet connexions were concerned, I was
making use of the internal modem, with the mwavem device driver.

Here is what happened this morning:

As I turned the system ON and watched the starting process, I noticed
a problem with the internal modem, which refused to start. The process
had stopped here, and everything seemed stuck. A CTRL-ALT-DEL brought
no result. I had to turn the power off and disconnect the battery, and

Upon restarting, I had to wait till fsck performed its job as
expected. One or two inodes were wrongly numbered, which was said to
be fixed, another 'unused' inode was deleted, and the system did
finally start. Modem must have started allright this time.

A this point, so far, X used to start. Automatically, without my
having to type 'startx' or anything. I would have preferred having to
do so manually, in order to be able to remain on the console whenever
chosen to do so... but I had so far no control on this with this
system as it was ; X was launched in any case, whether I wanted it or
not. Same thing upon disconnecting: I could not remain on console.

I'd better say that X was set to 'fvwm2': I don't like GNOME neither

This time, though, something very strange happened. The system
remained on the console, and displayed the following message :

- INIT: Id "X" respawning too fast: disabled for 5 minutes.

The word 'respawning' is really the one that was displayed, not
'responding'. I don't happen to know what 'respawning' means.

I therefore waited for five whole minutes... at the end of which
another similar message did display... and then a third one...

I then moved my mouse... and saw that a cursor did show. I typed a few
random characters followed by [return], and the system replied: 'login
incorrect', which made me realize that I was, indeed in the console
mode, able to type a login command, which I did.

After login, first command that came up to my mind: 'startx' !

The X system did start, as usual. This is, up to now, the last time
when I was able to launch X on that system. I was then able to launch
StarOffice, activate internet connexion, fetch my mail, launch PAN,
then Netscape... I must not forget to mention that, upon trying to
start ppp connexion, using 'pppon' script, the system had replied:
'couldn't open ppp database /var/run/pppd.tdb'. Despites this warning,
ppp connexion had started allright. After about half an hour, I did
disconnect from internet, and quit X. this time, by exception, I was
able to remain on the console, and this is from there that I typed:

'shutdown -h now'

During shutdown process, a few abnormal things happened, but I can't
make an accurate account of it, since nothing remained after shutdown
was complete. A few thing refused to shutdown, and filesystems refused
to dismount, as far as I had time to quickly read.

Upon restart, a few more abnormal things appeared:

configuring of serial port for mwave modem: FAILED !

Then, again, I was left on the console. Upon calling 'startx', I got:

-xauth: error in locking authority file /home/bd/.Xauthority

This message displayed four times in a roll.

Then: Fatal server error
Can't read lock file /tmp/.X0-lock
please report problems to...
giving up
xinit: no such file or directory (errno2): unable to connect to X
Xinit: no such process (errno3). Server error.
Xauth: error in locking up authority file /home/bd/.Xauthority.

However, this file /home/bd/.Xauthority does exist, it is 409 bytes
long, dated half an hour before or so. I can also notice a file
'.Xauthority-c', with zero bytes.

If I browse the ./xsession-error file, I get:

'ERROR: file '.fvwm2rc"' not found in $HOME or in /etc/X11/fvwm2.
Trying to read system rc file.

Sh: wmconfig command not found
xterm fatal Ioerror 32 (broken pipe) or KillClient or X server ":00"M

I then went into another shutdown process. Same errors as before did
appear. Upon restarting, I noticed the following error message, which
may have already existed the time before:

starting system logger /var/log/messages
syslogd: /var/log/messages
input/output error
syslogd: /var/log/messages: Input/output error.

Third shutdown. At first, for this third shutdown, the system
acknowledged in saying:

'system is going down for system halt NOW'.

But nothing more happenned, and the shell sign appeared as if the
command had been executed. Again, I typed: 'shutdown \h now', and,
this time, it did shutdown.

Third and fourth restarting tests have allowed me to trace a few
errors that I had not noticed before, even though they most likely
were already there:

- starting mwave manager now always fails in configuring serial port.

- Can't read lock file /tmp/./X0-lock.

At that time, I tried to re-initiate X, using Xconfigurator. But I
failed in doing so.

Thanks in advance for greatly expected help

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at:

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: