[ltp] Cisco 350 MiniPCI firmware problem and solution

Ivarsson, Torbjorn (T) linux-thinkpad@linux-thinkpad.org
Mon, 1 Dec 2003 14:52:39 -0600

Well, after 1+ on the phone with Cisco tech support, I managed to solve my problem myself... I realize now that I should have asked this list first if anyone has experienced something similar, and if and how you solved it.

Anyway, my problem was: Cisco supports the Aironet 350 MiniPCI card I have in my R40 with their 2.0 driver and 5.00.03 firmware. I know about the Linux driver alternatives... When I got my laptop I went to Windows and saw that the firmware currently was 5.02.19.

After downloading the files from Cisco, I "downgraded" my firmware to 5.00.03. Fine. The problem was that when I then rebooted back to Windows the firmware was "magically" upgraded to 5.02.19... Frustrated I called the friendly tech support (an engineer called back very quick) and we tried to fix the problem.

Well, during one of the many "please stay on the line, I'll put you on hold while I research the problem", I searched my harddrive for *.img files (the firmware is a .img file). A couple of them popped up, including a file named c:\windows\system32\drivers\pcx504b.img. A quick search on Google revealed that this file is related to Aironet. I renamed the file (.im_), "downgraded" my firmware again to 5.00.03 and rebooted. The "automagic" upgrade of the firmware to 5.02.19 was no more.

Apparently Windows or ACU or some other program, automatically loads the pcx504b.img file into the firmware without asking me... Wonderful. Windows strikes again.

Anyway, if I was the first one with this problem, the solution is now in the archives...

Why do I dual-boot with XP? Well... hmmm... it's pretty, isn't it? :)  Once I get Mandrake to work as I want, I may blow XP away. I run my music apps on my optimized XP desktop.

Thanks for listening,