[ltp] CD-RW on T30 won't write: Input-output error

James McKenzie linux-thinkpad@linux-thinkpad.org
Mon, 01 Dec 2003 19:52:08 -0700


I had a bad drive in my A22p which would not write a complete disk.  
Will the drive read a disk?  This drive that I had was damaged and IBM 
gladly replaced it under warranty.

James McKenzie

Whil Hentzen wrote:

>Hi folks,
>I have a T30 with a stock CD-RW that I've just started trying to use,
>and have not been able to write to a CD yet.
>I just bought a brand new box of Memorex 700 MB (write up to 48X) CD-RW
>discs so I don't think it's a media problem.
>When I run the command 
>  dd if=/dev/cdrom of=yarrow-i386-disc1.iso bs=3048
>I get an immediate 
>  dd: reading '/dev/cdrom': Input/output error
>  0+0 records in
>  0+0 records out
>When I run the command (as root)
>  cdrecord -scanbus
>I get 
>  0,0,0   0) 'MATSHITA' 'UJDA730 DVD/CDRW' '1.04' Removable CD-ROM
>Then I run 
>  cdrecord -v -eject speed=4 dev=0,0,0 yarrow-i386-disc1.iso
>I get a bunch of verbage (cuz of -v verbose mode) and at the end, it
>tells me it's 
> Performing OPC
> Starting new track at 0
>Track 01: 0 MB written
>Track 01: writing 600KB of pad data
>Track 01: Total bytes read/written: 0/614400 (300 sectors)
>Writing time: 13.1s
>Fixating time: 65.4 s
>cdrecord: fifo had 1 puts and 1 gets
>cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%
>And there's nothing on the CD. 
>If I try another file (not the 650 MB yarrow ISO), say, a 50K text file,
>I get a whole different set of errors, including the CD being spit out
>before write ("Drive needs to reload the media to return to proper
>status), and then Input/output error and so on.
>I've been working on this for several hours, trying different
>combinations, different CDs, and so on. No luck whatsoever and gosh am I
>getting frustrated.
>Do I have bad media, a bad drive, bad commands/processes, or should I
>just mosey on over to the "Too dumb to use a computer" sign?