[ltp] suse9: sound for gnome-events and DVDs after suspend and resume

Christoph Lehmann linux-thinkpad@linux-thinkpad.org
11 Dec 2003 22:46:33 +0100

Hi I run suse 9 on a t21 thinkpad
with acpi=off in the grub file

suspending and resuming works quite fine, BUT: after the resuming, the
sound for gnome -events are gone and so also the sound for DVDs.
AudioCD's are still ok...strange..

please could someone help me to fix this problem. Then I would have a
great suse-system on a t21-even with working suspend and resume

On Mon, 2003-11-17 at 05:52, vgough@arg0.net wrote:
> Worth a try..
> I had an extra laptop size drive laying around, so I put it in and
> installed SuSE 9 from scratch.  I've suspended and resumed twice so far
> and it has come back up perfectly (and quickly).  So, I'll have to test
> some of the differences between my upgraded system and the fresh
> install...
> I had ACPI disabled on both installs, and apmd running on both..  I
> noticed that the freshly installed /etc/sysconfig/powermanagement file has
> more/different settings -- I'll have to check differences in config
> files..
> thanks,
> Valient
> > 	I didn't upgrade, I installed from scratch.  I'm not sure what
> > detail I can provide that would be helpful to you, but if you name it,
> > I'll provide it.  I have the IBM a/b wireless card, a 60GB hard drive, and
> > otherwise stock hardware.  I disabled ACPI (which caused suspend problems)
> > by adding "acpi=off" to the kernel boot command line in the GRUB config
> > file (as well as "chkconfig acpid off").  I enabled APM with "chkconfig
> > apmd on".  I haven't had any troubles suspending or resuming (in fact,
> > it's damn fast to resume, like 2 seconds).  I always do it from X-Windows
> > though (I've heard of problems in the past with suspending from the
> > console, though that wasn't a SuSE issue AFAIK).  I used to have problems
> > suspending and resuming when I had a compact flash card in a PCMCIA slot
> > -- I haven't tried it with SuSE yet.
> >
> > 	The slow shutdown definitely sounds like ACPI to me -- when I
> > tried to suspend with ACPI it seemed to send the machine to "286 mode"
> > (about 8 MHz), and it took *forever* to shut down.  Look in
> > /boot/grub/menu.lst and make sure you have "acpi=off" in all your kernel
> > configurations.  Just turning off the acpid service is not enough.
> >
> > Aaron
> >
Christoph Lehmann <christoph.lehmann@gmx.ch>