[ltp] Suspend on IBM R40 2722-B3G

Fritsch linux-thinkpad@linux-thinkpad.org
Tue, 16 Dec 2003 23:47:25 +0100

Hi all, i am fighting several problems on my ibm R40 2722 -B3G

First of all acpi is not working as I supossed it do, I tried all 
kernels from 2.4.22-ac3 till 2.4.23-pac1
and 2.6.0test-ac3 till 2.6.0test11 with newest acpi patch.
cpu stepping went fine, but suspend to Ram and power off did not 
success, that`s why i am on APM again.

perhaps you can help with a specific problem:
I have two configurations: 2.6-test11 apm und 2.4.23 apm, and i two 
times the same issue:

Suspend works fine, the notebook falls asleep...
Wake Up ist even possible, but after some time, can be 10 minutes oder 
20 minutes, the laptop is just freezing, you can`t move
you pointer or switch consoles... no chance....
It runs over days, if you don`t suspend, so i think its no hardware issue...

I tried some workarounds (dri patches, alsa script to rmmod the modules 
I dont know how to go on....

Thanks for your help, if you need some information (syslog, dmesg etc.) 
just ask me for it.
I am running debian with (either xfree 4.3 or xfree 4.2.1)

thx in advance

Peter Frühberger

I never really hated the one true god
but the the god of the people I hated!