[ltp] Cisco Aironet 350 Mini PCI on an R40 running SuSE 9

Mike Evans linux-thinkpad@linux-thinkpad.org
Wed, 17 Dec 2003 08:23:53 -0700

Mike Evans wrote:

> Aha!  Success!  Thanks for the tip everyone.
> Mike Evans wrote:
I guess I spoke too soon.  I was testing at work, where we don't have an 
access point.  I was delighted to see my wireless' LED's light up.

Upon getting home, I booted back into SuSE, only to discover that for 
some reason the driver wouldn't load with 'modprobe airo_mpi'... I un 
tar'ed it again and re-compiled and installed it and got the LED to 
light up again.

I used 'iwconfig' to manually set all of my wlan settings.  iwconfig 
showed that the card had found my router and was reporting that I had 
around 55/100 signal strength.  But, still no internet connection.

As I thought the GUI would be easier, I brought up Cisco's acu utility 
and made a few changes.  Suddenly, the signal strength dropped, and 
subsequent tries to reconfigure with acu failed.

My next step was to use ifconfig (and later I manually created an 
itcfg-eth1 in /etc/sysconfig/network) to try to get things working.  It 
worked pretty well, but every time I run iwconfig, it shows the (wrong) 
settings I made in 'acu'.

Any ideas on how to fix this without (yet) another fresh install?

Anyone care to walk me through setting up a wireless connection 

Thanks a bunch.

>> Great!  I'll try it right now and report back.
>> Rich Smrcina wrote:
>>> I've been using Fabrice's driver for a couple of months (on RHL9) 
>>> and it
>>> works just wonderfully!
>>> On Tue, 2003-12-16 at 15:44, Joel Ebel wrote:
>>>> If it is a miniPCI card, you need mpi350, not airo.  You might also 
>>>> consider trying fabrice's driver.
>>>> http://bellet.info/~bellet/laptop/airo_mpi.HOWTO.txt
>>>> Joel
>>>> Mike Evans wrote:
>>>>> Wow, this is really frustrating me.  I bought an Aironet 350 
>>>>> specifically because Cisco provides Linux drivers for the card.  
>>>>> I've tried installing them by the provided script, which 
>>>>> successfully compiles the drivers and utilities.  According to the 
>>>>> instructions I'm then supposed to run 'insmod airo' which seems to 
>>>>> work fine.
>>>>> But, when I run the config utility provided by Cisco it reports 
>>>>> 'No Radio Found'  Has anyone successfully got this card running?  
>>>>> Can anyone help?
>>>>> Thanks.