[ltp] Cisco Aironet 350 Mini PCI on an R40 running SuSE 9

Ivarsson, Torbjorn (T) linux-thinkpad@linux-thinkpad.org
Wed, 17 Dec 2003 10:29:40 -0600

> -----Original Message-----
> From: Mike Evans [mailto:mike@public.arl.arizona.edu]
> Sent: Wednesday, December 17, 2003 10:24 AM
> I used 'iwconfig' to manually set all of my wlan settings.  iwconfig 
> showed that the card had found my router and was reporting that I had 
> around 55/100 signal strength.  But, still no internet connection.
> As I thought the GUI would be easier, I brought up Cisco's 
> acu utility 
> and made a few changes.  Suddenly, the signal strength dropped, and 
> subsequent tries to reconfigure with acu failed.
> My next step was to use ifconfig (and later I manually created an 
> itcfg-eth1 in /etc/sysconfig/network) to try to get things 
> working.  It 
> worked pretty well, but every time I run iwconfig, it shows 
> the (wrong) 
> settings I made in 'acu'.
> Any ideas on how to fix this without (yet) another fresh install?

I have had success in getting my card to work using the airo_mpi driver. Using Mandrake 9.2 on an R40 2722, this is what I did:

- Install the airo_mpi driver (of course...)
- In /etc/modules.conf add the line
	alias eth1 airo_mpi
  so that the driver loads up at reboot.
- I don't load the network-interface (eth1) at boot, instead I type (script):
	ifconfig eth1 up
	iwconfig eth1 essid 'my_essid'

The dhclient is run so that I can obtain an IP address. I've noticed that sometimes the ESSID reverts back to some default value ('tsunami'), or the strongest network around. It may work (or so it appears to me sometimes, though I cannot prove it 'scientifically') if you do the command:
	iwconfig eth1 commit

The problem I currently have is that once I have the card up and running, the firewall poses some challenge... So now I'm going to learn iptables... :)