[ltp] Cisco Aironet 350 Mini PCI on an R40 running SuSE 9

Fabrice Bellet linux-thinkpad@linux-thinkpad.org
Thu, 18 Dec 2003 16:08:26 +0100

On Wed, Dec 17, 2003 at 08:23:53AM -0700, Mike Evans wrote:
> I used 'iwconfig' to manually set all of my wlan settings.  iwconfig 
> showed that the card had found my router and was reporting that I had 
> around 55/100 signal strength.  

Is your card associated to your access point ?
/proc/driver/aironet/eth1/Status should report something like that in the
first lines :

Mode: 3bf

> But, still no internet connection.

Is the network interface configured ?
Does ifconfig report RX/TX packets ? Do these values increase ?

> My next step was to use ifconfig (and later I manually created an 
> itcfg-eth1 in /etc/sysconfig/network) to try to get things working.  It 
> worked pretty well, but every time I run iwconfig, it shows the (wrong) 
> settings I made in 'acu'.

ACU and iwconfig both work on the same level : the wireless parameters
configuration. That's the prerequise. So it is normal that ACU did overwrite
the previous parameters defined with iwconfig.

ifconfig (for a static IP configuration, or a DHCP client for a dynamic IP
configuration) works at the network interface level. Once the wireless
parameters are configured, the network interface needs to be configured too
(its IP address, netmask, default route, and so on). 

> Any ideas on how to fix this without (yet) another fresh install?
> Anyone care to walk me through setting up a wireless connection 
> step-by-step?

A very simple commandline-based wireless setup is the following 
(according everything is static) :

# wireless setup
iwconfig eth1 essid your_essid
iwconfig eth1 channel your_channel
iwconfig eth1 key xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xx

# network interface setup
ifconfig eth1 x.x.x.x netmask y.y.y.y up
route add default gw z.z.z.z