[ltp] Suspend/resume on R40e

Marc Schoechlin linux-thinkpad@linux-thinkpad.org
Sat, 20 Dec 2003 10:45:21 +0100

Hi !

On Sat, Dec 20, 2003 at 12:00:50AM -0800, As Wi wrote:
>    1. acpi seems to work, like I can see the status of the battery  (but
>    manually I have to do "insmod battery" and "insmod ac" to get this
>    results). If you try to "insmod processor" or "insmod thermal", it
>    certainly got stuck! The other good news is that the notebook switched
>    off by itself when it halts. The bad news: I experienced that sometime
>    my laptop could not boot up properly in the sense when I switched on
>    my machine, the screen just got blank, if you tried once more, it
>    might be started properly. Since I did not like such "bad news", I
>    returned back to fedora Core 1.

I run Debian/testing with Kernel 2.6.0test9 - booting and shutdown
always works well :-)
>    2. tg3 driver for the network card did not work as you said, I have to
>    use the driver from Broadcom, then it works properly.

I saw that there are many patches for the tg3-driver in the current
2.6.0-final-release - maybe the problem is solved now.
>    3. Installing Fedora Core 1 on R40e is also not without problems. I
>    read from many sources as well, that some problems occur when
>    installing Fedora or RedHat on R40e, e.g.
>    - the keyboard hangs when you were asked whether you want to check the
>    installation media (CD) or want to skip it. This I could handled by
>    passing the options "linux nousb" on boot. It works, but afterwards,
>    the GUI installations did not work. This could be handled either by
>    using text-based installations or passing the argument
>    "resolution=1024x768" on boot (if we insist to use GUI installation).

I deaktivated usb in the bios to install thy system - after activating
"hotplug" the keyboard works well :-)
>    4. As VGA driver automatically it used VESA generic. But, later I
>    chose to use ATI Radeon (generic).

This is also a option - i use the the radeon-driver:

 Install XFree4.3.0 from experimental

  deb http://ftp.de.debian.org/debian/ ../project/experimental main
  deb-src http://ftp.de.debian.org/debian/ ../project/experimental main

  apt-get -t experimental install x-window-system
  apt-get install x-window-system-core -t experimental
  apt-get install xserver-common -t experimental
  apt-get install xserver-xfree86 -t experimental

  Section "Device"
    Identifier  "Generic Video Card"
      Driver    "radeon"

  echo "deb http://dri.freedesktop.org/~daenzer/debian/dri-tTrTunk-sid/ ./">/etc/apt/sources.list
  cd kernel-source<version>
  cd /usr/src
  tar zxvf drm-trunk.tar.gz
  cd kernel-source<version>
  # Deaktivateing DRM
  make xconfig
  make-kpkg modules --initrd --revision=marc.1 --added-modules drm-trunk
  cd ..
  dpkg -i drm-trunk-module-2.6.0-test9_2003.10.05-1+marc.1_i386.deb

Unfortuneately XFREE says at starttime - that dri is not supported - the driver
runs well, but without fast opengl :-)

A friend said that hardcoding a older, but compatioble vga-adapter in the 
XF86Config-4, will help - he will send me a a directive to do this - 
maybe then it will works.

I will announce it in this thread.

Best regards

Marc Schoechlin

Gruss / Best regards  |  LF.net GmbH        |  fon +49 711 90074-413
Marc Schoechlin       |  Ruppmannstr. 27    |  fax +49 711 90074-33
ms@LF.net             |  D-70565 Stuttgart  |  http://www.lf.net