[ltp] Thinkpad 600E sound

wes schreiner linux-thinkpad@linux-thinkpad.org
Tue, 23 Dec 2003 12:34:45 -0600

arun kalmanje wrote:

> Hello All
> I have this IBM Thinkpad600E. On which windows 98, is working fine 
>  lan , sound, display.

That Windows is working is good, but it only means that the hardware 
isn't broken.  Windows can and will take advantage of the Plug-and-Play 
(PNP) interface on the the 600 series, so the configuration settings 
that you see Windows using may not be the same as what your 600E boots 
up into Linux with.  First thing, you must turn off "Quick Boot" in the 
BIOS.  With Quick Boot off the BIOS will initialize all hardware 
configuration settings before passing control to the booting operating 
system.  This won't affect Windows as it will still use the PNP 
interface to adjust the configuration setting to what it wants.  With 
Quick Boot off you can use PS2.EXE to view and set all of your hardware 
settings and know that those will be the settings used when you boot 
into Linux.

> I installed RedHat 7.3, kernel 2.4.18 and tried heaven and hell to 
> bring up the sound and have failed miserably.  I even tried this 
> Mandrake installation 8.2 that too is giving same errors as I was 
> getting with RedHat.
> I am putting down all the detail for my machine
> Details got by pressing F1 during system startup:
> Bios version ,date INET18WW

Your BIOS is old.  Go to
and get it current.

> Microprocessor Pentium(**) II processor 300PE MHz
> Memory is 64MB
> Model/Submodel/Revision FC/01/00
> Power management version 1.00
> Bios version 1.03
> Setup version 1.01
> Video version 1.15
> slave controller version 1.05
> Linux version is 2.4.18, redhat 7.3
> I have referred to almost all sites(i guess) discussing about setting 
> up Linux on thinkpad 600E
> My modules.conf is
> alias sound-slot-0 cs4232
> post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L 
> >/dev/null 2>&1 || :
> pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S 
> >/dev/null 2>&1 || :
> options sound dmabuf=1
> alias synth0 opl3
> options opl3 io=0x388
> options cs4232 io=0x530 irq=5 dma=1 dma2=0 mpuio=0x330 mpuirq=9
> whenever I try "modprobe cs4232", it returns with these messages
> /lib/modules/2.4.18/kernel/drivers/sound/cs4232.o init_module: no such 
> device
> Hint: insmod errors can be caused by incorrect module parameters, 
> including invalid IO or IRQ parameters
> /lib/modules/2.4.18/kernel/drivers/sound/cs4232.o: insmod 
> /lib/modules/2.4.18/kernel/drivers/sound/cs4232.o failed
> /lib/modules/2.4.18/kernel/drivers/sound/cs4232.o: insmod cs4232
> I tried installing alsa.. again when i do modprobe snd-cs4236( with 
> modules.conf changed appropriately), it returns the same error.

Have you verified the sound hardware settings with the output of lspnp 
or PS2.EXE? 

> I did a trace of the how the cs4232 drivers comes up.  The init of 
> this driver after initialization of chip calls ad1848_detect() in file
> ....

> This comment tends towards suspecting hardware

The hardware detection in the Linux sound drivers, both OSS and ALSA, 
doesn't work for the sound hardware in the 600E.  That is why you must 
have every setting correct before it will work, the driver can't detect 
anything right on its own.

> . But since windows is detecting , probing at the same address 
> successfully. And is able to play songs perfectly, disproves any 
> problem with hardware.

Problem is not hardware, but hardware configuration.  Windows can use 
hardware PNP interface to set hardware the way it wants.  Linux sound 
drivers won't do that for you.  Linux PNP is not in the stock 2.4.x 
kernels but it is in many vendor kernels, so if you have PNP support in 
your kernel you can use lspnp and setpnp to work with the PNP interface 
in a manual way.

> I checked /proc/irq and the IRQ 5 is free which is set in 
> modules.conf, also the Ioport 0x530 is free.

Not the place to check.  This just means that other hardware hasn't 
claimed those resources, not that your sound card is actually waiting there.

> I suspected the PCMCIA card so totally removed PCMCIA card support 
> from kernel aswell as the hardware(network) in the pcmcia slot. Still 
> the errors remain same.

No, your problem isn't one of bad hardware or drivers causing 
conflicts.  You just need to see how your hardware is set.

> Can anybody guess the problem. or suggest a solution. and save me from 
> getting frustrated.

No, we can't and shouldn't guess what incorrect setting or configuration 
is blocking your success.  You need to get you BIOS updated, make sure 
Quick Boot is off, and then take a long look at your configuration 
settings with PS2.EXE.  Ignore Windows, the settings it uses might not 
be the same as the BIOS and Linux will use. 

> Thanks in advance

Never thank people in advance, it implies that you won't bother to thank 
them in the future.