[ltp] pcmcia nic install on thinkpad 390x

Aaron J. Enright linux-thinkpad@linux-thinkpad.org
Tue, 21 Jan 2003 12:03:31 -0600 (CST)

Hello, all.

First, I have also posted this on the debian-laptop mailing list.  I 
apologize if you are getting this twice.

I have an IBM Thinkpad 390x, and have been having trouble getting a pcmcia 
nic to work on it with Debian Woody.

I just got this laptop last week.  Within an hour of getting it I had 
woody on it and everything (including the pcmcia nic) was working 
wonderfully. I was, alas, unhappy with the partation table and had to 

Now my installation of woody has problems with the pcmcia nic.  I've tried 
installing Woody many times in the past few days, but with little success.

-Sometimes, when I am configuring the pcmcia devices in the installation 
program, the configuation fails (the error message I get ony tells me that 
there was 'a problem configuring pcmcia devices')
-Other times the pcmcia devices do get configured successfully, but the 
installation program doesn't see that there is a network interface 
attached, and I am unable to configure the network.

The pcmcia nic I am using is a d-link dfe-690txd.

I currently have redhat 8 on the laptop and the nic was automagicly 
configured, without a complaint, by the installation program.  I don't 
find redhat near as fun as debain though, and am looking forward to 
getting Woody back on this machine.

It's really bugging me that this worked the very first time and not at all 
after that.  Ugh.

Any advice?


The first thing I do in the morning is brush my teeth and sharpen my tongue.
	-Dorothy Parker