[ltp] A31: cpu speed goes down

PSI-Systems linux-thinkpad@linux-thinkpad.org
Wed, 21 May 2003 19:56:02 +0200


I've now testet nearly everything which was suggested/I know. Problem is
still this: when I run the distributed.net-client my Thinkpad A31 2652M5G
clocks the CPU-speed down to 1,2GHz after a while.

I'v tried a 2.4.20 kernel with all power management disabled in kernel, also
machine check exception and only booting to init-level 1, removed all
kernel-modules but the CPU clocks always down and so keyrates and machine
speed goes down and never goes back to 1,8GHz.

I also tried acpi and CPU temperature reached to 81C but passive release
temperature is 89C (all values according to acpi in linux). I also
monitored the /proc/processor/ subdirectory but nothing changes there.

(under XP the problem doesn't exists and thought that there was I time it
also doesn't clocked down but I don't know what I've changed)

Does anyone know how I can prevent this?
Can anyone with a A31 and newest BIOS- and EC-versions run a
www.distributed.net client and check if keyrates/machine speed goes down?