[ltp] USB

Aaron Mulder linux-thinkpad@linux-thinkpad.org
Tue, 4 Nov 2003 18:00:55 -0500 (EST)

	It's been my experience that powered USB hubs are more likely to 
work than non-powered hubs.  I had one that could work either way, and 
caused lockups when not plugged in but worked fine when plugged in.  That 
was with a desktop, though, not my ThinkPad.

	I also had a problem with a USB keychain device that didn't seem
to fit far enough past the black plastic ThinkPad casing on the T40 to
make a good connection.

	I've also had problems with the USB2 driver after a 
suspend/resume, though the USB1 driver worked fine.


On Tue, 4 Nov 2003, Johnny Casey wrote:
> Paul Kaplan wrote:
> > Has anyone gotten the USB ports on a port replicator or an external USB2 hub 
> > to work correctly?  My USB devices work correctly when plugged directly into 
> > the ports on a T40 itself, but are flaky or totaly non-functional when 
> > plugged into the port replicator or the hub.
> > I'm using a Mandrake stock 2.4.22 kernel w/ 1Gb memory.
> > TIA
> > Paul
> I was helping someone a while ago share keyboard/mouse/printer etc 
> between two computers using a USB port replicator.  We went through 
> several port replicators before we found one that provided adaquate 
> performance.  This was under windows, but we had the same problems. 
> Devices behaving flaky or jumpy.  If you can return the port replicator 
> you might try a different brand.  Not all USB devices are created equal.
> Cheers,
> Johnny