[ltp] Cisco Wireless again

Joel Ebel linux-thinkpad@linux-thinkpad.org
Thu, 06 Nov 2003 15:36:44 -0500

I'm trying out Fabrice's cisco driver, and I'm having some issues using 
the wireless tools to control it.  If I start up the computer, load the 
module and run bcard, then the card seems to work fine (it even gets an 
IP from the DHCP server, which I don't quite get since I didn't run a 
dhcp client).  But, when I try to configure the card with iwconfig, I 
can get it to find the access point, but running dhcpcd doesn't get me 
an IP.  It send it out but never gets a reply.  What's more, if I do 
anything with iwconfig, and then run bcard, then it doens't work.  i 
have to unload the module and reload it, and then run bcard to get it to 
work.  Any thoughts here?  Maybe I'm missing something about iwconfig. 
I've tried all sorts of different commands with it.  The only one I have 
ot issue to associate with my AP is iwconfig eth0 essid any, but I've 
tried several others and none have let me get an IP with dhcpcd.  Anyone 
have any thoughts?  Fabrice in particular?  I'm still using 5.00.03 

By the way, I tried some of the other firmwares, but didn't get very 
far.  The later ones would load, but I could never get them to 
associate.  5.00.01 had some problems associating.  5.00.03 seems to be 
the most reliable one available, although I had numerous system crashes 
even using cisco's driver, and it even says to use 5.00.03.