[ltp] Cisco Wireless again

Joel Ebel linux-thinkpad@linux-thinkpad.org
Thu, 06 Nov 2003 16:58:02 -0500

That's pretty much what I'm doing.  I haven't found that setting the 
channel makes a difference if the mode is managed, but I tried doing it 
anyway.  It also doesn't seem to make a difference if I send the ap 
command.  I ran it just in case a few times, but I still don't seem to 
get a dhcp response.  I ran tcpdump and I see the packets going out, but 
nothing comes back.

In response to the other email, I apologize for the lack of details. 
I'm on a T40 running 2.4.22.  It's a slackware 9.1 system.


Heiko Rosemann wrote:
> On Thu, 6 Nov 2003, Joel Ebel wrote:
> [Problems with Cisco Wireless card]
> FYI, my sequence on bootup is:
> # Load the driver
> modprobe airo_mpi
> # Select channel
> iwconfig eth1 channel 7
> # Set ESSID
> iwconfig eth1 essid any
> # Wait for card to recognize network
> sleep 1
> # Register with access point and get IP, if AP available
> if iwconfig eth1 | grep xx:xx:xx:xx:xx:xx > /dev/null;
> then iwconfig eth1 ap xx:xx:xx:xx:xx:xx
>      dhcpcd eth1
> fi
> (xx:xx:xx:xx:xx:xx is my access point's MAC)
> Please note that
> a) This causes hotplug (or something else) to complain about a module load
>    failure because the module is already loaded
> b) You might need full paths - I just was too lazy to type them in
> c) If you skip the iwconfig eth1 ap xx:xx:xx:xx:xx:xx line, you won't get an
>    answer from your DHCP server
> d) This is a simple network, no security at all. If you need encryption,
>    there's surely gonna be more to do
> HTH, Heiko