[ltp] Fedora Core 1 on Antique 760 series

Richard Griffith linux-thinkpad@linux-thinkpad.org
Sun, 16 Nov 2003 19:31:11 -0500

While evaluating Fedora Core 1, I tried to install it on a 760XL. 
Although the install went smooth, the results had a few problems. The 
display was the first obvious defect, X only worked in 640x480 mode, not 
in 800x600. This display has been problematic with all the XFree86 4.x 
lines, so in some ways this was an improvement, since there at least was 
a display. After a long round of tinkering, with no improvement, I moved 
on. The next serious problem, and a real show stopper, is PCMCIA won't 
work. The only error reported is a pair of the familiar 'No IRQ known 
for interrupt pin A of device 00:0n.n. Please try using pci=biosirq.' 
messages. Attempting to follow the advice and pass pci=biosirq to the 
kernel results in kernel panic.

After some unfruitful tinkering, I moved the drive to a 760XD. X worked 
fine in 1024x768, but still no PCMCIA. The pcmcia_core module loads, but 
yenta_socket fails.  Worth noting this is not a hardware or bios 
problem, as I am using that same XD with Mandrake 9.1 to send this note. 
Mandrake also shows the irq error line on startup, but then everthing 
goes ahead and works fine. Red Hat 7.2, 7.3 and 8.0 have been used on 
the same hardware.

After some research, it appears very unlikely that pcmcia will work 
correctly on these models with the supplied kernel. The TI PCI1130 
Cardbus Bridge appears to be mishandled.

With this obstacle, I did not seriously investigate any further. If 
anyone has overcome this, I'd like to know how, but I thought a note of 
caution might spare some frustration to anyone who doesn't really just 
want a challenge.