[ltp] Kernel panicking a bit too often on a TP 600E + other symptoms

Jakub Hegenbart linux-thinkpad@linux-thinkpad.org
Mon, 17 Nov 2003 13:57:20 +0100 (CET)

Hi everyone,

I proudly entered the notebook users' legions buying a ThinkPad 600E, 2645-550, PII 300Mhz, 192 MB RAM, 6.4 GB HDD, CD-ROM, no floppy (a used notebook, of course. I installed Slackware 9.1, stock kernel and was running fine until cca 2 weeks ago, when the machine started freezing and locking up.

Some "case studies:"

* A simple freeze in X. 

-- The mouse pointer stops and system stops responding at all. Happens both when I touch trackpoint in order to move the pointer, (in slackware 9.1 it was often when running Mozilla or Netscape and srolling in a 40MB email folder, for example)

-- Often, after trying Ctrl-Alt-BkSp'ing or threating the naughty box any other way including the usage of the power swith, the screen goes black and the system emits 6-7 beeps (and the TP User Guide suggests visiting the vendor)

* An unexpected X shutdown (Signal #11, not indicated where it came from, I think)

* An unexpected restart (immediate, no init'ed shutdown - just black screen and BIOS screen, you surely know what I mean)

-- these both happen under the same circumstances (running xterm, xmms, mozilla...), there seems to be no dependency, i.e. i can't tell what exactly will happen in a particular situation.

* Screen goes black and either one or two leds either blink or shine constantly. Kernel panic, I suppose.

* (happeed once) - when touching the scrollbar in mozilla, the screen split into three parts - the lower half had shifted colors, the upper half was divided into left and right part, where the same pixmap (the original upper half squashed to 50% in width and with colors shifted - shifted in another way than the lower half) in both screen quarters quickly scrolling/cycling upwards. Then - black screen, beeps, lockup.

* (happened once - yesterday) In console, the screen first cleared, then interleaved columns appeared (column with a changing character - some columns with a still character - some empty columns - from the beginning until the right end of the screen). Then, some dump started to scroll quickly over the screen - some pointers and function names, kinda like stack trace, but scrolling few minutes?

* (several times) When i had the X running and an app freezed, i was still able to switch to an xterm/rxvt and write an command. I ususally used top or ps to dump processes, but after one-two unsuccesful tries (segmentation fault - on ps? Strange...) - black screen, some beeps.

* (2-3 times) In console, a supposedly stable app (yes, ps again, for example) dumped core and some lib****.so problem was reported (I'm sorry I don't remember what exactly it said - i should rather have written it down, an idea that came a bit late.). Then again, restart/freeze with beeps/lockup.


These problems started appearing some 2.5 weeks ago, the frequency seems to increase.

I *think* the "XaaNoXXXXX" options do help a bit, but the problems definitely do arise even in plain console, although less often - or is it just because I usually run rxvt's from X ? That, I cannot say, master Luke :/

I set the mem= kernel option (although 2.4 kernels should be fine, if i understood it correctly), no help.

Distros tried: Slack 9.0 + 9.1 (Kernels 2.4.20, 2.4.22, XFree86 4.3), Mandrake 9.1 (Kernel 2.4.22 MDK flavour + XFree 4.3, i hoped a different build could be of some help), Mandrake 9.0 (Kernel 2.4.19 MDK flavour + XFree 4.2.1 - wanted to try another X version), Knoppix 3.3 {2.4.22, XFree 4.3 - i suppose). No success.

I'll try W2k right now, just to try another OS (and possibly to finally do some work :/). The situation is very unfortunate, by now, my desktop is broken for sevral weeks because of similar reasons (it's just simpler, the screen goes black and CRT monitor goes sleeping, which indicates loss of video signal. I suspect the MB, since a short time before, USB died and the only PCI card working is the SB Live! 5.1, which was seated in it from the very beginning - a fact i recently discovered when i bought a USB 2.0 card that wasn't even detected. This doesn't relate to ThinPads directly, I just lost 100% of my working capacity, which is computer-dependent - school and book translation). If the W2k won't work, I'll apply for the warranty. I they do, I'll go for Debian stable, most probably, and start debugging.

And one more issue - I tried to check the memory with a bootable memtest86 3.0 CD, but the only thing that appear is the number 80xx, eigth-thousand-and-something, appears - repeatedly, one every few seconds. In an ordinary PC, the CD works just fine. 

Any suggestions? Thanks in advance...

(Brai)Init: going desperate :/

Jakub Hegenbart
Nejvýhodněji nakoupíte pračku,lednici, myčku, mrazničku, sušičku... a to s prodlouženou zárukou bezplatného servisu 2+2 roky. http://ad2.seznam.cz/redir.cgi?instance=64772%26url=http://ww=