[ltp] USB flash card reader

Bob Toxen linux-thinkpad@linux-thinkpad.org
Mon, 17 Nov 2003 19:08:36 -0500

On Wed, Nov 12, 2003 at 12:01PM, Joel Ebel wrote:
> From: Joel Ebel <jbebel@ncsu.edu>
> Subject: Re: [ltp] UCB flash card readers
> Reply-To: linux-thinkpad@linux-thinkpad.org

> Slackware 8.1 doesn't include hotplug if I remember correctly, so are 
> you installing the usbstorage module manually?  I assume you already 
> have usbcore and a host controller driver if your usb mouse works, but 
> that's not necessarily true.  What are the relevant lines in 
> /var/log/messages when you install the module and insert the device?  Is 
> the flash card in the reader when you plug it in?  Is lsusb available in 
> 8.1?  If so, what does it say?  If not, you may want to mount the 
> usbdevfs.  You can do it manually or put this in your fstab:
> none             /proc/bus/usb    usbdevfs    defaults         0   0
> Then look in /proc/bus/usb for some more info.

> Give some more details, and I'll see what I can do.  It's possible you 
> just need a newer kernel/usbstorage driver.

I installed hotplug from source.  I also tried loading usbstorage manually
and even building it into the kernel.  I've tried booting with the device
connected and not connected.  I tried plugging in the device after booting
with and without the memory card plugged in initially.

It always hangs in initializing.  The kernel both on the Thinkpad and my
generic (white box) tower is 2.4.18.  The Thinkpad has the PPDD encrypted
FS and IPSec compiled in but these should not affect anything.  I don't
even have sound and suspend enabled (yet).

Could there be something unusual or non-standard about the Thinkpad
w.r.t. USB or is this just some dumb error on my part.

> Joel


> Bob Toxen wrote:
> > I am unable to get my R41 Thinkpad to talk to a USB ImageMate SanDisk
> > reader, used to read the flash cards recorded by my old HP digital
> > camera.  It hangs "initializing" in the usb-storage module.

> > The R41 is running the 2.4.18 kernel on a Slackware 8.1 Distribution.  I
> > *AM* able to use my USB mouse (but haven't tried at the same time).

> > I *CAN* use the SanDisk reader on my tower 2.4.18-3 kernel on Red Hat 7.3
> > system by doing "mount -t vfat /dev/sda1 /mnt2".  There are no obvious
> > differences between the systems.  Any ideas?

> > Thanks,
> > Bob