[ltp] Experiences R40 under fedora Core 1

Frank Schmitt linux-thinkpad@linux-thinkpad.org
Wed, 26 Nov 2003 01:49:03 +0100


I just wanted to share my experiences while trying to get my R40
2722-3GG working under Fedora Core 1:

First of all I phoned IBM for a set of recovery CDs, they weren't to
happy sending them to me, so I had to find an reasonable reason why I
would want them.

Now that I had my recovery CDs, I deleted the HPA and installed
Partition Magic on the preinstalled Windows (great tool, doesn't need an
installed windows but can run from a diskette or USB stick) and
repartitioned the disk. I shrinked the Windows partition, created one
more primary partition behind it for hibernation, then one more primary
partition for /boot and an extended partition for /home and /.

Now I booted from the Fedora Cd, install went well, no problems. I told
the installer to install grub in /boot, booted Knoppix after the
install, saved the first 512 bytes of /boot to a file which I then
used to start grub from XPs bootloader.

After the first boot into Fedora, I found out that standby worked OOTB
while hibernation didn't. I changed the type of the partition which
should hold the hibernation data to A0 with fdisk, installed lphdisk,
told it to create hibernation data on the specified partition rebooted
and - nada. So I changed partitions type to hidden FAT16, called mkdosfs
and told phdisk.c (<http://samba.anu.edu.au/junkcode/>) to create the
file save2disk.bin on the partition. One more reboot and tada: Fn+F12
send my R40 to hibernate. The bad thing: After wakeup, X hang and Mouse
and Keyboard were unresponsive. The solution for this problem was not
to use the dri module for my Radeon 7500 mobile.

Speedstep worked, too after a "modprobe speedstep-centrino" so the only
thing missing for me was my Cisco Aironet 350 mini-pci card. After
searching in this group I decided I'd try the driver from
http://bellet.info/~bellet/laptop/. The latest driver compiled cleanly
(it isn't linked on the index file yet but you find it in the folder)
and kudzu even found my card, however iwconfig didn't work. After
installing Firmware 5.003 I was able to connect to my AP but Wep didn't
work, so one more time flashing the Firmware and now, with 5.001
finally everything is working.

I didn't try to get the modem working and the IrDA interface working yet
as I've got no use for both of them. All together I'm really happy with
my system now.

MFG Frank

Did you ever realize how much text fits in eighty columns? If you now consider
that a signature usually consists of up to four lines, this gives you enough
space to spread a tremendous amount of information with your messages. So seize
this opportunity and don't waste your signature with bullshit nobody will read.