[ltp] Fedora/2.4.22/wireless update

linux-thinkpad@linux-thinkpad.org linux-thinkpad@linux-thinkpad.org
Wed, 26 Nov 2003 11:58:03 +0000 (GMT)

Thanks for all the helpful replies (on and off list) concerning the
various miniPCI cards and 2.4.22 (Fedora).  I'm assuming if I did
want to upgrade from 802.11b and my current Cisco miniPCI, the IBM
a/b/g rather than the Intel miniPCI would be the one to go for?
Progress with the madwifi drivers sounds promising.

I'm particularly keen on 802.11g.  Has anyone actually confirmed this
as working?  Thanks for the confirmations on a and the linuxant info.

Back to my current problems with the Cisco miniPCI and the Fedora
2.4.22 kernel.  A mail off-list encouraged me to give the ugly
Cisco software another go, as I need Ad-Hoc mode, and I've got it
just about limping along.. *sometimes*!  I tried and tried with the
acu utility to generate a config eth1.cfg for Ad-Hoc mode with WEP,
but none of my changes in the GUI would take: then I had the idea
of copying my working /etc/eth1.cfg from Red Hat 9 and it worked.
Means I can never change my WEP key though..

The real problem I am facing is that I just cannot get bcard to work
at boot, as it did in Red Hat 9.  My /etc/modules.conf contains:

alias eth1 mpi350
post-install mpi350 /usr/bin/bcard

(bcard location because I'm using a compiled up RPM - have tried
with my own manual installation in /opt/cisco/bin too).  I've tried
"post-install eth1", changed order etc.  At boot the module's clearly
installed as the card starts flashing, but bcard doesn't work: I have
to manually run a bcard after boot.

Sometimes when I run bcard once booted, the whole system locks up
(the light for Caps Lock goes on and the system is unresponsive),
sometimes it takes and sometimes not.  If I boot into single user and
try and bcard, nothing happens, which is presumably why it doesn't
work at boot time.  I can't for the life of me work out why this
usually works on full bootup, but not single user/boot-time.

Has anyone managed to successfully enable your Cisco miniPCI at boot
time with the Cisco software in Fedora?