[ltp] Switching Between Networks - Problem

Rob Smith linux-thinkpad@linux-thinkpad.org
Sun, 30 Nov 2003 14:05:14 -0600

----- Original Message -----
From: "Hartmut Meyer" <hartmut.meyer@web.de>
To: <linux-thinkpad@linux-thinkpad.org>
Sent: Friday, November 28, 2003 1:10 AM
Subject: Re: [ltp] Switching Between Networks


Am Freitag, 28. November 2003 06:54 schrieb Rob Smith:

> Well, I enabled SCPM via command line interface. I had to remove a LOCK
> file in order to do this.

That can happen (leftover from a previously running instance), but doesn't

> Then, through YaST, I added Work, Home, and Away
> profiles.

I just tried to change profiles in SCPM, by issuing the command "scpm switch
home". After checking, and then verifying, it told me that the network group
would be modified. The program continued running, telling me that the
network service would have to be restarted. Alas, it bombed!

>From the best I can tell, after doing this a couple of times is that
something is occurring when it goes to restore the file /etc/resolv.conf
prior to loading the Default Profile. There is a line that says:
Restoring profile default
   restoring file /etc/resolv.conf Aborted

I can rm the /var/lib/scpm/#LOCK, but as soon as I run the command scpm -s
reload, it locks again. I am assuming that it has something to do with
/etc/resolv.conf, but I know that the network has been running normally when
I plugged it in at the office, where I am on DHCP. I was able to browse the
network through the GUI, pull files from a share created on my Win2k
workstation, and surf the Net.

I went into X to view my /etc/resolv.conf file, and it is an empty file. Is
this correct?

Rob Smith