[ltp] Switching Between Networks - Problem

Rob Smith linux-thinkpad@linux-thinkpad.org
Sun, 30 Nov 2003 17:16:13 -0600

----- Original Message -----
From: "Hartmut Meyer" <hartmut.meyer@web.de>
To: <linux-thinkpad@linux-thinkpad.org>
Sent: Sunday, November 30, 2003 4:23 PM
Subject: Re: [ltp] Switching Between Networks - Problem

> Hi,
> Am Sonntag, 30. November 2003 21:05 schrieb Rob Smith:
> > I just tried to change profiles in SCPM, by issuing the command "scpm
> > switch home". After checking, and then verifying, it told me that the
> > network group would be modified. The program continued running, telling
> > that the network service would have to be restarted. Alas, it bombed!
> >
> > From the best I can tell, after doing this a couple of times is that
> > something is occurring when it goes to restore the file /etc/resolv.conf
> > prior to loading the Default Profile. There is a line that says:
> > Restoring profile default
> >    restoring file /etc/resolv.conf Aborted
> I have never seen this. And I'm running scpm since SUSE LINUX 8.1. (also
> 8.2 and now 9.0).

Nothing like being a "newbie" with a unique problem!  ;-)

> > I can rm the /var/lib/scpm/#LOCK, but as soon as I run the command
scpm -s
> > reload, it locks again. I am assuming that it has something to do with
> > /etc/resolv.conf, but I know that the network has been running normally
> > when I plugged it in at the office, where I am on DHCP. I was able to
> > browse the network through the GUI, pull files from a share created on
> > Win2k workstation, and surf the Net.
> >
> > I went into X to view my /etc/resolv.conf file, and it is an empty file.
> > this correct?
> There is no general answer to this question. Whether or not the file
> /etc/resolv.conf should be empty depends on your setup (and possibly also
> what profile your running and also if a service has temporarily replaced
> original file) ...
> Anyway, I doubt there is a connection between thos #LOCK files and your
> /etc/resolv.conf

In the meantime, I checked another Linux box, and the only entries were the
machine's host name and the default gateway, so I'm guessing that this
doesn't matter all that much.

Any ideas?

Thanks for the help,

Rob Smith