[ltp] Suspend on T40, 2.6.0-test8

Jordan Benjamin linux-thinkpad@linux-thinkpad.org
Fri, 24 Oct 2003 13:33:42 -0700

It works! I can barely believe it! Kernel 2.6.0-test8-mm1, XFree86 with radeon driver, vesafb console (radeonfb is broken again 
in test8-mm1). I have everything compiled directly into the kernel, 
including ethernet and sound, and it seems fine. All I have to do is 
close the lid in an X windows session and it goes to sleep -- haven't 
tried with the console yet. 

Now for the madwifi and VPN...anyway, thanks for your help everyone!


On Thursday 23 October 2003 11:32, Julien Leproust wrote:
> On Thu, Oct 23, 2003, Jordan Benjamin wrote :
> > If your machine is suspending properly now, would you mind sending
> > me your kernel .config and dmesg output? Also, what does your
> > /proc/apm say?
> My T40p is running quite well a 2.6.0-test8-mm1, with APM, XFree
> 4.3.0 and a Debian. Have a look at my config files, it's behaviouring
> in a quite quantic way ;) With a 2.6.0-test7-mm1, the network card
> (e1000) was crashing every lot of packets, I had to wait for the
> watchdog to restart it or manually restart networking (it was worse
> with more modules loaded). It's been solved with 2.6.0-test8-mm1, but
> now I get a nice kernel oops in "umounting local filesystes" while
> halting or rebooting...
> Suspending works well with X (radeon driver) and console (vesafb),
> except console fonts are completely broken, don't know why.
> ~% cat /proc/apm
> 1.16ac 1.2 0x03 0x01 0x00 0x01 100% -1 ?
> HTH,