[ltp] Supend-To-Disk with Kernel and ACPI-Patch

Mario Giammarco linux-thinkpad@linux-thinkpad.org
Tue, 12 Oct 2004 14:21:10 +0200

On Tue, 2004-10-12 at 12:54 +0200, Niels Stargardt wrote:
> > > > I think correct parameters at lilo prompt are: resume2=/dev/hda8
> > > > for suspend2 and resume=/dev/hda8 for old suspend.
> > > I thought, these parameters should only use for software-suspend? 
> > > Software-Suspend doesn't work at my Computer  :-(. Or had I set
> > > resume or resume2 by normal suspend? Try  them please. 
> Ok I try them, here is my grub/menu.lst
> title           Debian GNU/Linux, kernel
> root            (hd0,1)
> kernel          /boot/vmlinuz- root=/dev/hda2 pmdisk=/dev/hda8 resume=/dev/hda8 resume2=/dev/hda8
> initrd          /boot/initrd.img-
> savedefault
> boot
> So every possibility is checked, but it doesn't work :-(
> I tried to let the option in the kernel-config "Default Resume Partition" empty, but it doesn't work.

Very strange, in my case it worked (I have other problems as you can see
in my post).

Please note that with echo "4" in proc acpi you use old software suspend
method so you must use only resume= on reboot
With echo "disk" in /sys you must use resume2 ONLY.