[ltp] X30, Intel 830M: DRI won't work

Alex Deucher linux-thinkpad@linux-thinkpad.org
Thu, 28 Oct 2004 09:23:02 -0400

On Thu, 28 Oct 2004 04:09:03 +0200, Heiko Rosemann
<heiko.rosemann@gmail.com> wrote:
> Hi everyone,
> I finally took some time (of my healthy sleep - gotta be up for work
> in another four hours again :-)) to fiddle around a little more with
> my Thinkpad X30. Finally succeeded with a stable X-Server (Xorg
>, Build 09 October, XFree kept locking up) but still no DRI.
> ISTR I had it working once, during the 2.4 era, so I cannot really go
> back to that working setup...
> What I did was the following:
> - Installed Xorg
> - Installed dri-package (snapshot from - well, it's yesterday by now :-) (10-27)
> - Unpacked kernel (2.6.9final)
> - Compiled kernel with agpgart as a module (support only for LX/BX/GX,
> I8xx, E7x05), ACPI, no DRI.
> - Rebootet, reinstalled dri-package
> - Inserted the agpgart-module:
> - dmesg spoke to me: "Linux agpgart interface v0.100 (c) Dave Jones"

On the 2.6 series kernels you need to load the agp chipset driver as
well as agpgart, eg, intel-agp.ko.


> - Inserted the i915-module:
> - dmesg: "[drm:i915_fill_in_dev] *ERROR* Cannot initialize the agpgart module."
> - dmesg: "i915: probe of 0000:00:02.1 failed with error -22"
> - Started the X-Server with startx which came up just fine, except for
> dri, als glxinfo told me:
> "name of display: :0.0
> display: :0  screen: 0
> direct rendering: No [...]" (If there is any more interesting output
> of glxinfo, I will happily post the entire output)
> - and Xorg.0.log contains the entries:
> "(EE) GARTInit: Unable to open /dev/agpgart (No such device)
> (WW) I810(0): /dev/agpgart is either not available, or no memory is
> available for allocation.  Using pre-allocated memory only." (entire
> log is attached)
> /dev/agpgart exists, is root.root and 666. For the memory issue, I
> tried turning down the ColorDepth, but with 8bpp still the same
> problem as with 24bpp. I guess the error is already somewhere between
> the agpgart and the i915, but I am at a complete loss concerning how
> to find and solve that error. (except for maybe waiting for it to
> disappear in an older/newer dri-package and/or kernel)
> If anyone of you has any idea about where to take a closer look at,
> please be so kind and drop me a mail. Tell me about anything I could
> have missed - it's quite some time since I recompiled XFree for the
> nvidia-driver to work, and I've always put together what I found and
> hoped it would work :-)
> G'Night everyone,
> Heiko Rosemann