[ltp] Re: X60s w/t kern 2.6.19-rc1-git: two BUG warnings

Martin Lorenz linux-thinkpad@linux-thinkpad.org
Mon, 16 Oct 2006 08:08:46 +0200

On Fri, Oct 13, 2006 at 05:47:56PM +0200, Adrian Bunk wrote:
> On Tue, Oct 10, 2006 at 08:28:26AM +0200, Martin Lorenz wrote:
> > Dear kernel gurus,
> > 
> > whatever I do and whic problem I seem to get fixed new ones arise:
> > 
> > now I loose ACPI events after suspend/resume. not every time, but roughly 
> > 3 out of 4 times.
> > 
> > the only errornous things I see in the logs are those: 
> >...
> Which was the last working kernel?

have I already answered?
I am not sure

well it seems, that 2.6.18 worked as expected but had other sufferings

with the latest git I see no difference 
there is an new BUG warning in msi.c:680 - not the e1000 anymore, as far as
I can see it.

[50436.222000] CPU: After all inits, caps: bfe9fbff 00100000 00000000
00000940 0000c1a9 00000000 00000000
[50436.222000] Intel machine check architecture supported.
[50436.222000] Intel machine check reporting enabled on CPU#1.
[50436.222000] CPU1: Intel Genuine Intel(R) CPU           L2400  @ 1.66GHz
stepping 08
[50436.275000] usb 4-2: USB disconnect, address 3
[50436.481000] usb 4-2: new full speed USB device using uhci_hcd and address
[50436.508000] Trying to free already-free IRQ 20
[50436.531000] BUG: warning at drivers/pci/msi.c:680/pci_enable_msi()
[50436.531000]  [<c0103bd9>] dump_trace+0x69/0x1af
[50436.531000]  [<c0103d37>] show_trace_log_lvl+0x18/0x2c
[50436.532000]  [<c01043d6>] show_trace+0xf/0x11
[50436.532000]  [<c01044d9>] dump_stack+0x15/0x17
[50436.532000]  [<c02090a6>] pci_enable_msi+0x78/0x22e
[50436.533000]  [<c025837d>] e1000_open+0x64/0x176
[50436.534000]  [<c029b695>] dev_open+0x2b/0x62
[50436.536000]  [<c029a1a3>] dev_change_flags+0x47/0xe4
[50436.537000]  [<c02ce443>] devinet_ioctl+0x252/0x556
[50436.538000]  [<c029143a>] sock_ioctl+0x19e/0x1c2
[50436.540000]  [<c016987f>] do_ioctl+0x1f/0x62
[50436.540000]  [<c0169b07>] vfs_ioctl+0x245/0x257
[50436.541000]  [<c0169b65>] sys_ioctl+0x4c/0x67
[50436.541000]  [<c0102dc3>] syscall_call+0x7/0xb
[50436.541000] DWARF2 unwinder stuck at syscall_call+0x7/0xb
[50436.542000] Leftover inexact backtrace:
[50436.542000]  =======================
[50436.650000] usb 4-2: configuration #1 chosen from 1 choice
[50436.744000] ata1: waiting for device to spin up (7 secs)
[50437.192000] usb 4-1: new full speed USB device using uhci_hcd and address
[50437.351000] usb 4-1: configuration #1 chosen from 1 choice
[50437.682000] CPU1 is up

should I disable msi?
would this break something in an non obvious manner (because I already tried
a kernel without msi and it diden't seem to me that something broke.

on the other hand, it diden't give me the ACPI events back
and the echo reset > /proc/acpi/ibm/hotkey trick dosen't work either.
no idea what it did in the first place that made me think it was a good
idea... well, it did work once but I have no idea why. havent succeeded to
bring back the events a second time

should I try to unload / reload modules?
haven't done that yet

Dipl.-Ing. Martin Lorenz

            They that can give up essential liberty 
	    to obtain a little temporary safety 
	    deserve neither liberty nor safety.
                                   Benjamin Franklin

please encrypt your mail to me
GnuPG key-ID: F1AAD37D
get it here:

ICQ UIN: 33588107