[ltp] T61 immediate resume on suspend

Takis Diakoumis linux-thinkpad@linux-thinkpad.org
Thu, 13 Nov 2008 11:51:20 +1100


further on this... i have narrowed it down to the modules uhci_hcd
ehci_hcd. if i manually unload them, it works and comes back fine (and
then i have to reload them)

if i am not using the hibernate scripts (as most docs on thinkwiki
suggest), what is the recommended approach for unloading and reloading
modules for suspend?


On Thu, 2008-11-13 at 11:04 +1100, Takis Diakoumis wrote:
> Hi
> i've got a T61 (dreaded nvidia) with debian testing. i reinstalled the
> whole system recently and have since been unable to get suspend to work.
> on suspend, it goes through the motions then immediately resumes. i had
> this once before and have no idea what did to fix it or indeed if it
> fixed itself.
> it happens on swsusp and suspend2. i do not have hibernate installed
> (though i used to in the previous working version - having it now makes
> no difference anyway). i have also tried with and without uswsusp
> installed - same result.
> i'm using kernel i currently have bios v2.24.
> i have checked these reports (among many others), but nothing worked for
> me:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/190422
> http://www.linuxquestions.org/questions/debian-26/suspend-not-working-on-latptop-t61-598891/
> http://forums.fedoraforum.org/showthread.php?t=160325
> suggestions appreciated.
> thanks
> Takis