[ltp] how to make the console not blank out and change resolution?

linux-thinkpad@linux-thinkpad.org linux-thinkpad@linux-thinkpad.org
Sun, 24 Oct 2010 02:52:00 +0800

Allow me to ask a stupid question.

Somewhere near this point in the dmesg messages, the console blanks and
becomes a different resolution.

[   8.135936] Marking TSC unstable due to TSC halts in idle
[   8.137762] processor LNXCPU:00: registered as cooling_device0
[   8.144690] Switching to clocksource acpi_pm
[   8.223513] input: PC Speaker as /devices/platform/pcspkr/input/input5
[   8.754683] i801_smbus 0000:00:1f.3: PCI INT B -> Link[LNKB] -> GSI 11 (level, low) -> IRQ 11
[   8.768920] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   8.853142] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   8.872591] intel_rng: FWH not detected
[   9.160625] IBM TrackPoint firmware: 0x0e, buttons: 3/3

All I know is it happens around the time /etc/rcS.d/S02udev is run.

How do I temporarily not make this console blanking not occur?

You see, when that happens, whatever that was on the screen goes away.
Nor was most of what was on the screen at that point stored in dmesg or
in any /var/log/* file, not can it be ShiftPgUp'ed to anymore.

So I would like to stop the blanking just one time to get a look at what
was on the screen at that point.

Reading http://www.debian.org/releases/stable/i386/ch05s03.html.en , I
tried adding fb=false to the boot parameters. However I see in dmesg the
frame buffer still there. Well they ought to correct that. Let's see
what else I can try.

I added "blacklist drm" in /etc/modprobe.d/* but that is ignored too.
Apparently that is for later items, not stuff so early in the boot

I tried to make the /etc/init.d scripts not run in parallel, so that
debugging messages I put in them would reveal just which one is the
blanking the screen culprit. But of course how to not make them run in
parallel is a big mystery, despite the insserv man page.
dpkg-reconfigure what package? initscripts:no, insserv:no.

On my desktop, blanking does not occur, only on my laptops.

Let's see, maybe if I turned off one of these:
7 matches for "drm" in buffer: kernel-parameters.txt.gz
     46:	DRM	Direct Rendering Management support is enabled.
    793:	gamma=		[HW,DRM]
    886:	i810=		[HW,DRM]
   1413:	mga=		[HW,DRM]
   2094:	r128=		[HW,DRM]
   2514:	tdfx=		[HW,DRM]
   2786:	Add more DRM drivers.
However as there is nary a word about how to use these parameters there
in that document, one dares not experiment. Maybe on the boot line I
just do gamma=false i810=false mga=false r128=false tdfx=false ?
But judging from what happened when I did fb=false, I think that
wouldn't work either.