[ltp] Fn-F12 ignored by gnome-power-manager

Frédéric Boiteux linux-thinkpad@linux-thinkpad.org
Wed, 1 Sep 2010 09:31:29 +0200


  I've recently upgraded my thinkpad X31 from Debian Lenny to Squeeze,
and have some hard times (mostly with graphic) ; I've noted that Fn-F12
don't do anything anymore, whereas it worked [so] well before. As this
kind of problem isn't new, I dig in the list and re-read the Thinkwiki
article, but I'm a bit lost :-(

  I noted that ACPI and HAL see the F12 pression : 'lshal -m' tells :
platform_thinkpad_acpi_logicaldev_input condition ButtonPressed = hibernate
and 'apci_listen' tells :
button/suspend SUSP 00000080 00000000
but nothing happens (I have a Gnome destktop with gnome-power-manager running).

  I already had a setup for Fn-F5 to call a 'toggle_wlan' script with
halevt (as in the ThinkWiki site), and tried to add a second handle for
the F12 key, and it called the /etc/acpi/hibernatebtn.sh button. When
I press Fn-F12, halevt runs the /etc/acpi/hibernatebtn.sh, which looks
if a power manager is
running, and in this case, simulate an ACPI key event with the command :
acpi_fakekey $KEY_SUSPEND
which… make another HAL suspend event, catched by halevt, which
repeatedly call the /etc/acpi/hibernatebtn.sh, i.e. it's an endless loop !

I don't know where to look, it seems it's gnome-power-manager which doesn't react
to the HAL or ACPI event, but didn't find similar bug reports in Debian BTS, and don't know
how to debug this…

  Do you have any hints to solve my problem ?