[ltp] T402s EC not supportd under Linux?

Alessandro Crismani linux-thinkpad@linux-thinkpad.org
Sun, 01 May 2011 17:26:15 +0200

Hi everybody,

I just installed the tp-smapi module on Arch Linux, stock kernel. I 
tried loading it and it failed. From dmesg I saw:

# dmesg | tail -n 1                                                                                                                       
[ 9065.486315] thinkpad_ec: no ThinkPad embedded controller!

I then tried to load the thinkpad_ec module and got:

# modprobe thinkpad_ec 
FATAL: Error inserting thinkpad_ec (/lib/modules/2.6.38-
ARCH/extra/thinkpad_ec.ko.gz): No such device

The ThinkWiki suggests to upgrade the BIOS upon receiving the first error. 
However, I'm already running the latest available BIOS for the T420s (see the 
version below). I've tried to see if the controller is recognized, but from

# dmidecode -s bios-version && dmidecode -t11
8CET32WW (1.09 )
# dmidecode 2.11
SMBIOS 2.6 present.

it seems that Linux doesn't see it.

Should I write to Lenovo support or simply waiting will probably get me a 
working BIOS or controller? Anybody else have this laptop? I am still new to 
Lenovos, any help is appreciated. I am willing to provide more info if it is