[ltp] x100e ethernet

Jason Brooks linux-thinkpad@linux-thinkpad.org
Thu, 12 May 2011 08:39:19 -0700

You need to check out this site. It is related to WOL.
--- FROM the link>
There is a widespread problem with the Linux driver for the Realtek
8168/8169 cards where the modules load properly and the card is
visible but no link is detected. E.g.:

    Jun 21 18:28:41 localhost kernel: r8169: eth0: link down
    Jun 21 18:28:41 localhost kernel: ADDRCONF(NETDEV_UP): eth0: link
is not ready

There are lots of details and suggested solutions from the Ubuntu
people. None of the suggestions worked for me, however. Several of
them suggest configuring the card under Windows, but the box
containing this device is a single-boot linux fileserver. The
=E2=80=9Cwake-on-LAN=E2=80=9D functionality seems to be implicated, but not=
 in a way I
can see how to fix.

After much head-banging (in the bad sense), I found a simple solution:

(1) Install ethtool
(2) Modify /etc/network/interfaces as follows (substitute your r8169
interface for =E2=80=98eth1=E2=80=B2 and other settings accordingly):

    iface eth1 inet static
    pre-up /usr/sbin/ethtool -s eth1 autoneg off

This did the trick for me where no other solution would work. Of
course, link autodetection no longer occurs, but that=E2=80=99s a small pri=
to pay for connectivity.

This is a Debian etch installation using a slightly more recent kernel

As an interesting side note, on this new box, the interface appears as
eth0 in the kernel logs, but is actually mapped as eth1. Similarly, a
second Ethernet interface appears in the log as a different device
number than that by which it is referenced. Any ideas why?

Update 6/22/08: Still not getting 1000BaseT (Gigabit), however. If I
force 1000BaseT with ethtool -s eth1 speed 1000, the link goes down
again (even with autoneg off). The same card in another box, however,
detects the link and goes to 1000BaseT automatically. So I=E2=80=99m stuck =

Update 6/24/08: Linux 2.6.26-rc5 fixes the problem 100% for me.

[Tags]realtek, r8169, linux, drivers, hacking[/Tags]

---- end of link>>

Hope this helps.

On Wed, May 11, 2011 at 10:16 PM, Tino Keitel <tino.keitel@tikei.de> wrote:
> On Wed, May 11, 2011 at 15:30:01 -0700, Clinton Baker wrote:
> [...]
>> When it dies, it just seems to stop routing traffic. =C2=A0I can ping it=
> Pinging the IP of the Ethernet interface does not use the Ethernet port
> at all. =C2=A0The kernel considers the IP as local and routes it over the=
> interface.
> Regards,
> Tino
> --
> The linux-thinkpad mailing list home page is at:
> http://mailman.linux-thinkpad.org/mailman/listinfo/linux-thinkpad