[ltp] ThinkPad T520 won't boot Linux from Intel SSD 320

Martin Steigerwald linux-thinkpad@linux-thinkpad.org
Thu, 19 May 2011 23:07:59 +0200

Am Donnerstag, 19. Mai 2011 schrieb Martin Steigerwald:
> Hi!

Re to meself,

> Today I got my new ThinkPad T520 + Intel SSD 320.
> After creating a Windows recovery medium, I put the SSD into an
> external eSATA case to circumvent secure erase freeze by BIOS and then
> issued a secure erase as described in
> https://ata.wiki.kernel.org/index.php/ATA_Secure_Erase
> As Intel has an own utility to securely erase the SSD I consider that
> it supports that procedure. I wanted to replace the default crypto key
> by which the Intel SSD transparently encrypts data by a new randomly
> generated one.
> This worked, the previous data was gone and I installed Debian Wheezy
> on the system. First with GPT and BIOS Boot Partition as well as EFI
> System partition for possible future use. But I used grub-pc which
> apparently installed into the BIOS Boot Partition.
> The ThinkPad T520 did not boot this. And before I was able to read the
> last message it replaced them by a boot menu. Trying again gives a
> blinking cursor, some SSD accesses and the boot menu again.
> Ok, so I tried some stuff - like syslinux, like gptsync and what not -
> and after that wiped out the GPT partition table my parted mklabel
> msdos command as well as a dd at the beginning and end of the SSD.
> Then I reinstalled Debian another time with MBR partitioning scheme.
> GRUB 2 again installed without errors.
> But the ThinkPad T520 BIOS didn't boot this either.

Ok, I got it. I do not know what it was, but what I did was:

1. dd zero sector 2 to 2047 (the sector before the first partition)

2. update grub-pc to 1.99-3

3. install grub again, but I think this wasn't strictly necessary

4. set bootable flag on partition with /boot, just in case

And then boot this:

And well, it did.

I think I am cured from any GPT / EFI experiments on that laptop for now. 
I think there might have been some GPT / EFI traces on the laptop and the 
BIOS decided that it just don't want to boot this. Or can it really have 
been the bootable flag? I doubt it.

Anyway, now it boots and it does so pretty fast.

Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7