[ltp] BIOS update on Thinkpad X220 fails

Yves-Alexis Perez linux-thinkpad@linux-thinkpad.org
Wed, 16 Nov 2011 10:52:34 +0100

On sam., 2011-10-29 at 17:17 +0100, Ricardo Reis wrote:
> On Sat, 29 Oct 2011, Johannes Bittner wrote:
> > Any idea why this doesn't work?
> It has to do with the kind of isos lenovo is doing.
> Someone at the notebook forum recommended this and it worked like a
> charm:
> http://www.floccinaucinihilipilification.net/blog/2011/10/2/updating-the-bios-of-a-thinkpad-x220-using-linux.html
> (ref link for credit:
> http://forum.notebookreview.com/lenovo-ibm/575569-linux-x220-9.html#post7991348
> )
Any idea how to combine that with an extlinux/syslinux boot? (I usually
boot bios upgrades from either my /boot partition or from an usb key
which has an extlinux installed and can boot various bios updates, dos
utilities etc.)

Trying the usual:

label x220t
	menu label x220t bios update
	linux memdisk 
	append iso
	initrd /8duj12uc.iso

doesn't work. With the initial image, it fails with the same error as
initial poster (upgrade just hangs). With the images after geteltorito,
it doesn't boot. Relevant messages during boot:

El Torito BCD sanity check failed.
El Torito bot catalog sanity check failed.
MEMDISK: Image seems to have fractional end cylinder
MEMDISK: bootstrap too large to load