[ltp] T61 Optical drive

John Jason Jordan linux-thinkpad@linux-thinkpad.org
Wed, 18 Apr 2012 23:09:45 -0700

On Thu, 19 Apr 2012 02:42:09 +0100
Richard Neill <rn214@richardneill.org> dijo:

>> I'm out of ideas, short of tearing the computer apart. Has anyone
>> here had problems with the optical drive in a T61 or T60? Any
>> solutions? Any other suggestions?
>I suspect that if you are able to read the drive properties, for
>   sudo hdparm -I /dev/cdrom
>then the electronic connection is fine.

That produced an amusing interlude. I ran the command and it produced
several pages of error messages. In order to see the error messages
better I decided to drag the terminal window larger (I use Xfce). Then
i ran the command again, and this time it locked up the GUI or, at
least, the mouse would not work and I had an hourglass on top of the
terminal window that was frozen. The keyboard worked, so I
Ctrl-Alt-F2'ed to a command line and ran top. One by one I killed all
the apps that I was running (lots of Firefox windows, etc.). Each time
I went back to the GUI but it was still stuck. Eventually I killed all
the apps but the terminal window, and it was still stuck. So I did
poweroff and then rebooted. 

>Next, I'd try reading a commercial CD-ROM (one of the mass-produced 
>stamped ones rather than a burned one) - these are higher contrast.
>This checks your drive basic functionality.
>Then try reading one of the burned discs you have (already knowing
>that that disk reads OK in another computer). This verifies the read
>laser sensitivity.
>Finally, check the procedure for burning CDs (not DVDs) using
>different branded media and not necessarily at full speed.

The problem is failing to mount ANY media, burned or blank.

>I also recommend a lens-clean: either using a lens-cleaning disc or 
>using a small amount of (wet) lens-cleaner for a camera with a Q-tip.
>This does make a difference. You won't hurt the lens, provided you are 
>very gentle.

The drive is brand new. It should not need cleaning.

>Lastly, it might be worth suggesting some alternatives to using
>optical CDs: Have you come across Unetbootin (for installations)?
>Also, the combination of scp  or rsync over ssh  may be helpful.

I do have Unetbootin, but I thought it was just for making bootable USB
sticks. At least, that is all I ever used it for. 

>P.S. If you get read errors, does dmesg say anything of interest?

I don't get read errors. When the drive works it works perfectly.

After rebooting the drive still would not work. But since I wasn't
running anything else yet I decided to try the hdparm command again. If
it locked up the GUI, nothing lost. But this time it ran fine and saw
the optical drive.

After running the hdparm command I tried a blank DVD again. And this
time it mounted and I could burn it fine. And following that I burned
four more DVDs, all without issue.

At this point I am wondering if the problem is that the device is not
mounting on boot. Hence, running the hdparm command woke it up. I know
little of such things, so I am just throwing notions in the air. But I
have noticed on this Fedora 16 x86_64 (Xfce) Thinkpad that other
removable devices do not mount automatically. For example, if I stick a 
USB drive into a port it appears in Thunar, but is grayed out. If I
click on it in Thunar it becomes black and then I can read the drive. 

I suppose I need to reboot a few times and after each reboot run the
mount command to see if it is mounted.