[ltp] Re: [W510] how to undo nouveau -> nvidia driver change in debian?

Tom Roche linux-thinkpad@linux-thinkpad.org
Mon, 03 Dec 2012 18:27:47 -0800

more data from new development:

Tom Roche Mon, 03 Dec 2012 17:01:06 -0800
> I just installed the nvidia driver on a Thinkpad W510 via debian
> packages--now the box will boot through GRUB, but now only shows a
> blinking white cursor in the upper left corner of the screen after
> showing the usual boot messages. How to restore my previous
> configuration?


> [After cold boot,] it failed to go graphical: I got only a blinking
> white cursor in the upper left corner of the screen.

> Worse: when I tried to go to a virtual terminal (via C-A-F1), I got
> the usual login prompt only for a few seconds; then it switched back
> to the blinking cursor @ upper left! I got the same result for
> C-A-F2 through C-A-F6.

> Worse still: I got the same results booting to recovery mode on the
> current kernel, as well as booting to previous kernels.

After some thought, I realized that I had only tried rebooting to 3.x
kernels. So I cold-booted and chose kernel=2.6.39-2 from GRUB: now it
boots and goes graphical, but only to GNOME 2. After login, I get a
dialog saying

> GNOME 3 failed to load

> GNOME 3 failed to start properly and started in the fallback mode

Note I also get

$ lsb_release -ds
Linux Mint Debian Edition
$ cat /etc/debian_version 
$ uname -rv
2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011
$ inxi -Gx
Graphics:  Card NVIDIA GT216 [Quadro FX 880M] X.Org Res: 1600x900@60.0hz 
           GLX Renderer N/A GLX Version N/A Direct Rendering N/A
$ cat /var/log/Xorg.0.log
[    26.073] 
X.Org X Server (1.12.2 RC 2)
Release Date: 2012-05-19
[    26.073] X Protocol Version 11, Revision 0
[    26.073] Build Operating System: Linux 3.2.0-2-amd64 x86_64 Debian
[    26.073] Current Operating System: Linux tlrw510 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011 x86_64


[    27.582] (II) LoadModule: "nouveau"
[    27.603] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    27.629] (II) Module nouveau: vendor="X.Org Foundation"
[    27.629] 	compiled for 1.12.1, module version = 0.0.16
[    27.629] 	Module class: X.Org Video Driver
[    27.629] 	ABI class: X.Org Video Driver, version 12.0


So what should I do to enable it to boot 3.x kernels with GNOME >= 3?
And then to fix the {battery life, power management} problem (detailed @


) that got me here in the first place ...

TIA, Tom Roche <Tom_Roche@pobox.com>