[ltp] Re: confused about power managment with T520 with Debian with no DE

linux-thinkpad@linux-thinkpad.org linux-thinkpad@linux-thinkpad.org
Sun, 5 Feb 2012 14:55:23 -0800

Thanks to all who have responded. Unfortunately I still haven't resolved
the issue.

Jochen Spieker suggested I try xfce4-power-manager. I have tried that, an=
it only partly works. It will turn off the monitor after a set time, but =
can't get it to put the computer into suspend mode (sleep, AKA suspend to
RAM) at all. Some of the options are greyed out (unavailable): the only
option I get for "When laptop is closed" is "nothing" or "lock screen".
Both the suspend and hibernate options under "Set computer inactivity
sleep mode" are greyed out as well. I wonder if the fact that I still hav=
gnome stuff loaded interfers with it? And of course it wouldn't help when
I am using console only (no X).

Tom Roche gave a link to a great tutorial for configuring the sudoers fil=
which I learned from  :-) (https://help.ubuntu.com/community/Sudoers)

Claudius Hubig gave some examples of capturing the acpi event to invoke a
shell script. I haven't been able to duplicate this.

When I run acpi_listen and press the FnF4 (sleep) button I get:
^@^@button/sleep SBTN 00000080 00000000 K

I then created a script:
$ cat /etc/acpi/suspend.sh

and the shell script:
$cat /etc/acpi/events/fnf4-suspend
event=3D^@button/sleep SBTN 00000080 00000000 K

This produces no output of any noticeable kind when I subsequently press
the FnF4 button (after of course marking the scripts executable and
rebooting).I also tried sustituting "3D" for the "^@" with no change.

Perhaps I have the form of the command wrong?

Also, funny, when I try bash completion with man pm-<TAB> I only get a
beep... though bash completion generally works for me.

This is weird- under Gnome it worked just fine.... but I don't want to go
back to Gnome. I _can_ now invoke pm-suspend or pm-hibernate manually, bu=
I sure would like to get into sleep/suspend mode by closing the lid, or a=
least by pressing the FnF4 button...

My system:
Lenovo Thinkpad T520
Intel i5-2410 with onboard graphics (i915) only
Intel SSD drive, 4GB RAM
Debian, using i3wm

Thanks for any further help you can provide.
Keith Ostertag