[ltp] Thinkpad Edge 0578 special keys problem

paulo_cv linux-thinkpad@linux-thinkpad.org
Wed, 25 Dec 2013 07:33:06 -0800 (PST)


I am the victim of all the symptoms posted here

The thread clearly states that this happens for Windows users of all
different versions and architectures and have also read numerous forums
threads for linux users as well (including me of course)

Essentially special keys (volume, brightness control) stop working for some
undetermined reason. This started years ago and pulling the battery has
always been the only way to get those keys back.

I am more interested in knowing what triggers those keys to stop working and
since I am a Gentoo Linux user I've been trying to tweak the kernel and see
if I can overcome this annoying problem.

Enabling ACPI_EC_DEBUGFS a few weeks ago led me to think the problem was
solved since I spent a good amount of days without having to do the battery
pull. Today however I ran into the issue again and I am back at square 1.

There's obviously the chance of a BIOS issue even though I have updated to
the latest from Lenovo.

I am posting here hoping that someone has run into the same problem or can
at least offer some next steps.

I have recently tried adding this boot parameter "ec_intr=0" and am
currently testing it.

View this message in context: http://linux-thinkpad.10952.n7.nabble.com/Thinkpad-Edge-0578-special-keys-problem-tp20880.html
Sent from the Linux Thinkpad mailing list archive at Nabble.com.