[ltp] Temperature increase after S2Ram

Henrique de Moraes Holschuh linux-thinkpad@linux-thinkpad.org
Sun, 7 Jul 2013 02:47:25 -0300

On Sun, 07 Jul 2013, Paul Bolle wrote:
> On Sat, 2013-07-06 at 23:39 +0200, Paul Bolle wrote:
> > 0) It seems I'm running into a similar issue but on a X61. On an
> > uninteresting Gnome 3 session, running roughly 99% idle, the CPU
> > temperature usually stays below 50 C. But after a few suspend and resume
> > cycles, still on an equally undemanding, session the CPU temperature
> > rises a bit above 60 C.
> > 
> > 1) The rather course test
> >     watch "cat /proc/cpuinfo | grep MHz"
> > 
> > suggests that at this moment the second (of two) cores is stuck at 2 GHz
> > (which I guess is full throttle). Could that be causing this?
> Somehow, taking that second core offline and online again, through
> the /sys/devices/system/cpu/cpu1/online interface, stops it running at
> full throttle. After that a mostly idle system will have both cores
> running at 800 MHz (the lower bound, apparently) most of the time. CPU
> temperature then remains below 50 C again.

This is not the first report that 3.10 is a dud.  Make extremely sure you
have _NOT_ enabled the new "full tickless" mode, that thing is broken to
kingdon come [either that, or it gets all zombies to come out in the open].

Check with powertop and turbostat to make sure the cores are idling
properly (i.e. hitting c3 and c6), as well.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh