[ltp] spotty wireless with t520 w/Intel wifi and xubuntu 13.04

Steven J. Owens linux-thinkpad@linux-thinkpad.org
Thu, 24 Oct 2013 16:20:28 +0000

On Wed, Oct 23, 2013 at 08:50:48PM -0600, Derrick Karpo wrote:
> Did you ever get any answer to this question?  I am curious if the
> problem may be that you have 2 network managers running (ie. Network
> Manager and wicd) and that they are competing with each other.

     No, no answer to the question.  I don't have wicd installed.  I
recently tried adding the line "options iwlwifi 11n_disable=1" to
/etc/modprobe/iwlwifi.conf, which now looks like this:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211 
options iwlwifi 11n_disable=1

     This helped somewhat - for a few days the disappearing ESSID
problem went away.  Every now and then wifi would seem to freeze for
20-30 seconds, but it resumed on its own.  Then last night I had the
disappearing ESSID again, and again when I went to use my machine this

     This is the forum thread that suggested the 11n_disable=1.  It
appears they're troubleshooting my exact issue, but although the
thread is marked Solved, I'm not sure they solved it.  The final
comment from the OP makes a reference to shutting off bittorrent, and
I'm not using bittorrent.


Steven J. Owens
puff@darksleep.com / (412) 401-8060 cell 
| "I'm going to make broad, sweeping generalizations and strong,
|  declarative statements, because otherwise I'll be here all night and
|  this document will be four times longer and much less fun to read.
|  Take it all with a grain of salt." 
|  - http://darksleep.com/notablog