[ltp] TP Yoga - touchpad psmouse lost sync, buttons hanging / freeze

Nicole Faerber linux-thinkpad@linux-thinkpad.org
Thu, 31 Jul 2014 17:45:07 +0200

Since I reported this issue I thought I should also post the "solution":
The hardware was bad.

After trying around stuff not only the touchpad behaved awkward but also
the trackpoint started to get mad at me for touching it. And finally
also the keyboard did mysterious things upon my gentle strokes :)

The solution turned out to be a hardware fault. I called the Lenovo
service because I have a next day on site contract. After a week they
came and changed the mainboard (next day on-site | after a week - get
it?). While opening the case the fault became obvious. The securing
lever of the FFC connector of the keyboard / touchpad / trackpoint unit
was simply missing. If you know FFC connectors then this tells you that
this connectors will only have proper contact by accident. After
changing the mainboard all came back to normal, including the touchpad.

So I have a well behaving machine now, great!

The downside of this is that the technician that did all of that turned
my just two weeks old machine into a state that I wouldn't even accept
when buying a used machine. The screws are now visibly used and worn
out. While changing the display, because it had the ghosting problem, he
scratched the lid. The cover stickers on the screws are crumbled and
hardly sticking anymore etc. Worst of all, all FFC connectors the guy
had to disconnect (almost all that are in the machine) usually have a
securing adhesive tape glued over the connector and the cable's end. He
peeled them off but did not apply new tapes. And since he peeled them
off with bare hands they do not stick anymore. Why are those there in
the first place if he does not care to replace them?

In the end after reassembling everything the case now has several spots
where it shows gaps between the parts. The palmrest now produces a nasty
click-click-eek noise when moving the hand while typing. And the changed
display was so improperly replaced that it shows clear signs of
mechanical stress, i.e. a spot with wrong colors in the upper right corner.

Is it normal that Lenovo service people do not use ESD protection? I was
really amazed that the guy not even bothered to ground himself nor the
workspace while handling ESD sensitive parts.

I should have requested an exchange of the machine instead of an on-site
repair :( Now I have to waste my time describing all the faults to the
service and wait for another brutal machine slaughter - presumably
finding my precious machine in a worse state after the next "service".
Great service, this is.

If someone from Lenovo is reading this: PLEASE take EXTRA care to
instruct, teach and train your service people properly! The kind of
service I experienced here is completely unacceptable. The guy was
friendly but was clearly unable to cope with the task. If I would not
have sat down with him three and a half hours correcting him with
several mistakes he made I would have an only half working machine now.


Am 12.07.2014 13:58, schrieb Nicole Faerber:
> Hi!
> Yesterday I received my shiny new Thinkpad Yoga. Most stuff works right
> out of the box (I did install Debian testing) but I have a severe issue
> with the touchpad, especially the buttons, that are now part of the
> touchpad (a big drawback of the Yoga and some other new Thinkpad models).
> Everything works fine until I press one of those buttons. After that the
> psmouse driver reports lost sync and the mouse pointer either goes
> haywire or it gets stuck and most of the time recovers after some seconds.
> Since I only played around briefly with the installed Win8 (I have no
> interest in Win8) I can not 100% sure tell if it worked there. But I had
> the impression that Windows showed the same issues - each time I clicked
> a "mouse" button, the pointer disappeared and only the touchscreen
> worked for a moment.
> This seems pretty strange to me. It feels like a hardware defect but on
> the other hand the buttons are part of touchpad and the touchpad works
> as far as moving the mouse pointer is concerned.
> Here is what the kernel (I am running 3.15.5 now) sais about that:
> [    2.102001] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1,
> id: 0x1e2b1, caps: 0xd001a3/0x940300/0x127c00, board id: 2911, fw id:
> 1514409
> [    2.102009] psmouse serio1: synaptics: serio: Synaptics pass-through
> port at isa0060/serio1/input0
> [    6.601021] psmouse serio2: alps: Unknown ALPS touchpad: E7=10 00 64,
> EC=10 00 64
> [    8.502683] psmouse serio2: trackpoint: IBM TrackPoint firmware:
> 0x0e, buttons: 3/3
> [   29.798333] psmouse serio1: TouchPad at isa0060/serio1/input0 lost
> sync at byte 1
> [   29.799455] psmouse serio1: TouchPad at isa0060/serio1/input0 lost
> sync at byte 1
> [   29.800550] psmouse serio1: TouchPad at isa0060/serio1/input0 lost
> sync at byte 1
> [   29.801631] psmouse serio1: TouchPad at isa0060/serio1/input0 lost
> sync at byte 1
> [   29.802739] psmouse serio1: TouchPad at isa0060/serio1/input0 lost
> sync at byte 1
> [   29.802744] psmouse serio1: issuing reconnect request
> Is this simply a (yet) unsupported touchpad version? The "Unknown ALPS
> touchpad: E7=10 00 64, EC=10 00 64" suggests this. Or is this device
> really broken, i.e. broken hardware?
> BTW: Since I read in some forum posts that some people have similar
> issues (other laptops) when UEFI is still active I tried to switch to
> "legacy only" but same behavior. I also booted the Windows recovery from
> USB stick since it also has GUI and mouse pointer already and at least
> the recovery version also goes haywire when one of the buttons is pressed.
> I also tried various parameters to the "psmouse" kernel module but
> nothing helped.
> Apart from this issue the machine is superb and I would really be pretty
> p*ssed if would have to return it - which would surely mean several
> weeks being without it. So if someone has an idea how to fix this I
> would be very very grateful!
> Many thanks!
> Cheers
>   nicole

kernel concepts GmbH       Tel: +49-271-771091-12
Sieghuetter Hauptweg 48
D-57072 Siegen