[ltp] Trying to get Suspend to RAM working on an X31

John Magolske linux-thinkpad@linux-thinkpad.org
Thu, 9 Oct 2014 08:14:29 -0700

Thanks everyone for the suggestions, see comments in-line below.

I went ahead and upgraded from Debian Stable to Testing thinking maybe
a more recent kernel and more recent versions of uswsusp (package that
provides s2ram) & pm-utils might help. Unfortunately, still unable to
suspend to RAM.

* Dan Saint-Andre <saint@grillongroup.org> [141004 15:39]:
> The last time I fought this issue, I learned that suspend-to-RAM
> [aka, sleep] required a suitable swap space.

A swap partition is set up and the `free` command shows available space.

* Stefan Monnier <monnier@iro.umontreal.ca> [141004 16:19]:
> Which X11 driver are you using?  If you use the Free Software one, then
> I can't help, but if you're using the proprietary driver, then I'd
> suggest you try the Free Software driver instead.

I'm not starting up X, my sequence is boot up into a framebuffer
console, log in as root, issue commands -- rmmod to unload some
modules then pm-suspend or s2ram with various options.

In terms of graphics card drivers, after upgrading to Testing there
was something new when booting up:

    radeon 0000:01:00.0: firmware: failed to load radeon/R100_cp.bin
    [drm:r100_cp_init] *ERROR* Failed to load firmware!
    radeon 0000:01:00.0: failed initializing CP (-12).
    radeon 0000:01:00.0: Disabling GPU acceleration

So per suggestions on a forum somewhere that discussed those error
messages and a Radeon card (but not having to do with suspend issues)
I installed the firmware-linux-nonfree package and those error
messages went away. But the not-waking-from-suspend issue remained.
Although now, instead of a blank screen I see vertical stripes, two
clusters of three going from the bottom of the screen to the top.

> You might also like to try `s2ram' instead of `pm-suspend' (using
> pm-suspend runs s2ram, but by removing the extra stuff that pm-suspend
> does might help track down the origin of the problem).

I actually tried s2ram first, but read somewhere it was deprecated
in favour of pm-suspend. I don't think pm-suspend runs s2ram, as I
un-installed uswsusp did `which s2ram` saw "s2ram not found" and
and pm-suspend kept functioning as before.

* Alexandre Kalmeijer <sacha.kalmeijer@gmail.com> [141005 11:06]:
> Google for TLP and configure it to your needs.
> RESTORE_DEVICE_STATE_ON_STARTUP= should solve your problems with
> hibernation/ sleep.

Hadn't heard of TLP before, so I went ahead and installed it. Looks
like an interesting alternative to laptop-tools, will have to play
with it later to see how it does with battery life. Unfortunately, for
now I find it does not do anything to alleviate my wake from suspend

One other thing I tried last night is installing OpenBSD on this
machine. I'd heard ThinkPad support is decent with OpenBSD as the devs
"dogfood" & use thinkpads when running thier OS. Running the `zzz`
command to suspend seemed to work a little nicer -- the screen turned
off without a need for anything like `radeontool light off` ... but
on waking from sleep the display was frozen with lots of vertical

I'm wondering if the issue is just that this is an old graphics card
that is no longer supported... granted it is a pretty old machine by
today's standards. But it has IMO a very nice keyboard, I like the
"tall-screen" format, and it has enough power for my needs (running a
shell, tmux, vim, elinks, ncmpcpp etc).

In any case, any further clues appreciated!


John Magolske