[ltp] trackpoint, touchpad, and buttons suddenly dead

Andreas Ronnquist mailinglists at gusnan.se
Sat Aug 26 16:37:21 CEST 2017

On Sat, 26 Aug 2017 11:38:11 +0000 (UTC),
David Griffith<dave at 661.org> wrote:

>While I was using my T420, the touchpad suddenly stopped responding,
>as did the mouse buttons and trackpoint.  The output of xinput shows
>no PS/2 keyboard/mouse interface available.  The output of lsmod shows
>that the psmouse module is unused.  I checked the BIOS to see if
>somehow these got turned off.  I turned them off, rebooted, then
>rebooted again, and turned them back on again.  I removed the hard
>drive and inserted a Windows 7 hard drive I keep around for when I
>need to use Windows on this laptop. Still nothing.  All this while,
>the keyboard has continued to function as expected.
>What could have caused the ps/2 mouse interface to fail like this?

I run into the same problem quite often with my T420 - but I
probably don't notice it as much, since I most often use Synergy [1]
for my mouse and keyboard on the laptop. As in your case, when I run
into this, a reboot isn't enough to get it working, but I do get the
touchpad and the other stuff working when I put the computer into
hibernate, and get it back up.

1: https://symless.com/synergy

-- Andreas Rönnquist
mailinglists at gusnan.se
andreas at ronnquist.net

More information about the Linux-Thinkpad mailing list