[ltp] LID on X260

Carles Pina i Estany linux-thinkpad@linux-thinkpad.org
Mon, 2 Jan 2017 08:46:48 +0400


TL;DR: any kernel parameter to stop the closing the LID detection?
(because of a hardware problem). Or, is this only controled by hardware?
(it even happens before Linux booting up).

We have a 1 month old X260 here (currently we are on an Antarctic
expedition, so we don't have access to shops). When moving the screen it
flickers and goes black: I think that it detects that the LID has been
closed even if it hasn't.

It happens even before Linux boots. I'll try to disable ACPI on the BIOS
but obviously it's some type of falty hardware. We've tried echo LID >
/proc/acpi/wakeup as I think it was suggested in some message some time
ago without any luck. I've also tried killing acpid.

Besides disabling ACPI on the BIOS if possible (and I think that might
not work) any other idea of what could be done? (we are now from Cape
Town to Hobart, but we only have 2 days there and we would like to not
have to buy/replace the laptop).

I'm thinking of some Kernel parameter to stop this happening, for

Thank you very much,

Carles Pina i Estany
	Web: http://pinux.info || Blog: http://pintant.cat
	GPG Key 0x8CD5C157
	Current Latitude: -47.6728 Longitude: 56.1630